# CVE-2025-43866: Vantage6 Server JWT secret not cryptographically secure

> The vantage6 server uses a predictable UUID1 for its JWT secret, allowing attackers to forge tokens and bypass authentication.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-m3mq-f375-5vgh, PYSEC-2025-221

## What is CVE-2025-43866?

CVE-2025-43866 is a low-severity vulnerability in vantage6, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vantage6 is an open-source infrastructure for privacy preserving analysis. The JWT secret key in the vantage6 server is auto-generated unless defined by the user. The auto-generated key is a UUID1, which is not cryptographically secure as it is predictable to some extent. This vulnerability is fixed in 4.11.0.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2025-43866?

3 open source packages ship an affected version, including vantage6-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6-server` | PyPI | All versions | 4.11.0 |
| `vantage6-server` | PyPI | All versions | 4.11.0 |
| `vantage6-server` | PyPI | All versions | 4.11.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2025-43866?

Upgrade vantage6-server to 4.11.0 or later.

## Is CVE-2025-43866 being exploited?

There is no known exploitation of CVE-2025-43866 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43866 and fix it if it is affected.

What it is: CVE-2025-43866 is a low-severity vulnerability in vantage6, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43866 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6-server (PyPI): affected all versions; fixed in 4.11.0
- vantage6-server (PyPI): affected all versions; fixed in 4.11.0
- vantage6-server (PyPI): affected all versions; fixed in 4.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43866/ (Markdown: https://insights.sbomify.com/CVE-2025-43866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43866
- OSV: https://osv.dev/vulnerability/CVE-2025-43866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43866/
Summaries are generated and may contain mistakes; the official description above is the record.
