{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-43903 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-43903 is a medium-severity vulnerability in Freedesktop Poppler, published on 18 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-43903 and fix it if it is affected.\n\nWhat it is: CVE-2025-43903 is a medium-severity vulnerability in Freedesktop Poppler, published on 18 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-43903 in the wild and no public exploit code.\n\nAffected product: Freedesktop Poppler. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-43903/ (Markdown: https://insights.sbomify.com/CVE-2025-43903/index.md)","id":"CVE-2025-43903","markdown":"https://insights.sbomify.com/CVE-2025-43903/index.md","name":"CVE-2025-43903","record":{"aliases":["CLSA-2026-1784038553","CLSA-2026-1784899428","DEBIAN-CVE-2025-43903","ECHO-9071-56c9-378a","GHSA-4w9g-4h2x-7qxq","JLSEC-2026-87","MGASA-2025-0143","OESA-2025-1476","OESA-2025-1477","OESA-2025-2520","OESA-2025-2521","OESA-2025-2522","SUSE-SU-2025:1434-1","UBUNTU-CVE-2025-43903","USN-7471-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PDF rendering library","requires_auth":"none","summary":"Attackers can forge digital signatures in PDF documents because the library fails to verify specific PKCS7 signatures, compromising document integrity.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"poppler","vendor":"freedesktop"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"NSSCryptoSignBackend.cc in Poppler before 25.04.0 does not verify the adbe.pkcs7.sha1 signatures on documents, resulting in potential signature forgeries.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP6","SUSE:Linux Enterprise Module for Package Hub 15 SP6","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in Poppler","id":"CVE-2025-43903","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"freedesktop:poppler","products":["freedesktop:poppler"],"type":"security_feature_bypass","year":"2025"},"n_packages":7,"n_references":1,"next":{"headline":"Privilege escalation in Slurm","id":"CVE-2025-43904"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/suse/poppler\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2025:1434-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/suse/poppler\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:1434-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt5","purl":"pkg:rpm/suse/poppler-qt5\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:1434-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15 SP6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt6","purl":"pkg:rpm/suse/poppler-qt6\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015%20SP6","source":"SUSE-SU-2025:1434-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler","purl":"pkg:rpm/opensuse/poppler\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:1434-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt5","purl":"pkg:rpm/opensuse/poppler-qt5\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:1434-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["24.03.0-150600.3.13.1"],"introduced":["0"],"last_affected":[],"package":"poppler-qt6","purl":"pkg:rpm/opensuse/poppler-qt6\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:1434-1"}],"prev":{"headline":"Not used","id":"CVE-2025-43901"},"products":["Poppler"],"published":"2025-04-18","related":[{"cvss_score":8.8,"headline":"Integer overflow in n/a","id":"CVE-2018-21009","kev_date_added":null,"published":"2019-09-05"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2019-12293","kev_date_added":null,"published":"2019-05-23"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2019-10872","kev_date_added":null,"published":"2019-04-05"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2019-9543","kev_date_added":null,"published":"2019-03-01"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2019-9545","kev_date_added":null,"published":"2019-03-01"},{"cvss_score":8.8,"headline":"Integer overflow in Poppler","id":"CVE-2017-2820","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":7.8,"headline":"Integer overflow in n/a","id":"CVE-2022-38171","kev_date_added":null,"published":"2022-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["freedesktop"]},"summary":"Attackers can forge digital signatures in PDF documents because the library fails to verify specific PKCS7 signatures, compromising document integrity.","url":"https://insights.sbomify.com/CVE-2025-43903/"}