{"answers":{"affected":"3 open source packages ship an affected version, including github.com/linkerd/linkerd2. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-43915 in the wild and no public exploit code.","fix":"Upgrade github.com/linkerd/linkerd2 to 0.0.0-20250212165942-faa3f617eef5 or later.","what":"CVE-2025-43915 is a medium-severity denial of service vulnerability in n/a, published on 5 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-43915 and fix it if it is affected.\n\nWhat it is: CVE-2025-43915 is a medium-severity denial of service vulnerability in n/a, published on 5 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-43915 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/linkerd/linkerd2 (Go): affected all versions; no fix listed\n- github.com/linkerd/linkerd2 (Go): affected all versions; fixed in 0.0.0-20250212165942-faa3f617eef5\n- github.com/linkerd/linkerd2 (Go): affected all versions; fixed in 0.0.0-20250212165942-faa3f617eef5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-43915/ (Markdown: https://insights.sbomify.com/CVE-2025-43915/index.md)","id":"CVE-2025-43915","markdown":"https://insights.sbomify.com/CVE-2025-43915/index.md","name":"CVE-2025-43915","record":{"aliases":["GHSA-42mr-jpwh-m9rv","GO-2025-3664","MINI-8x6q-x4pc-jhh5","openSUSE-SU-2025:15144-1"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Linkerd service mesh","requires_auth":"none","summary":"Attackers can cause resource exhaustion in Linkerd proxy metrics, leading to denial of service for service mesh deployments.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"buoyant","vendor":"linkerd"},{"product":"linkerd","vendor":"linkerd"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"In Linkerd edge releases before edge-25.2.1, and Buoyant Enterprise for Linkerd releases 2.13.0–2.13.7, 2.14.0–2.14.10, 2.15.0–2.15.7, 2.16.0–2.16.4, and 2.17.0–2.17.1, resource exhaustion can occur for Linkerd proxy metrics.","ecosystems":["Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Linkerd resource exhaustion vulnerability","id":"CVE-2025-43915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Open redirect in api.sonos.com","id":"CVE-2025-43916"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/linkerd/linkerd2","purl":"pkg:golang/github.com/linkerd/linkerd2","source":"GO-2025-3664"},{"ecosystem":"Go","fixed":["0.0.0-20250212165942-faa3f617eef5"],"introduced":["0"],"last_affected":[],"package":"github.com/linkerd/linkerd2","purl":null,"source":"GHSA-42mr-jpwh-m9rv"},{"ecosystem":"Go","fixed":["0.0.0-20250212165942-faa3f617eef5"],"introduced":["0"],"last_affected":[],"package":"github.com/linkerd/linkerd2","purl":"pkg:golang/github.com/linkerd/linkerd2","source":"GHSA-42mr-jpwh-m9rv"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.0.20250520T172319-1.1"],"introduced":["0"],"last_affected":[],"package":"govulncheck-vulndb","purl":"pkg:rpm/opensuse/govulncheck-vulndb\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15144-1"}],"prev":{"headline":"Privilege escalation in PowerProtect Data Domain BoostFS for Linux Ubuntu Feature Release","id":"CVE-2025-43914"},"products":["n/a"],"published":"2025-05-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-19","vendors":["n/a"]},"summary":"Attackers can cause resource exhaustion in Linkerd proxy metrics, leading to denial of service for service mesh deployments.","url":"https://insights.sbomify.com/CVE-2025-43915/"}