# CVE-2025-43915: Linkerd resource exhaustion vulnerability

> Attackers can cause resource exhaustion in Linkerd proxy metrics, leading to denial of service for service mesh deployments.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2025
- **Updated:** 19 May 2025
- **Also known as:** GHSA-42mr-jpwh-m9rv, GO-2025-3664, MINI-8x6q-x4pc-jhh5, openSUSE-SU-2025:15144-1

## What is CVE-2025-43915?

CVE-2025-43915 is a medium-severity denial of service vulnerability in n/a, published on 5 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Linkerd edge releases before edge-25.2.1, and Buoyant Enterprise for Linkerd releases 2.13.0–2.13.7, 2.14.0–2.14.10, 2.15.0–2.15.7, 2.16.0–2.16.4, and 2.17.0–2.17.1, resource exhaustion can occur for Linkerd proxy metrics.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-43915?

3 open source packages ship an affected version, including github.com/linkerd/linkerd2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/linkerd/linkerd2` | Go | All versions | None |
| `github.com/linkerd/linkerd2` | Go | All versions | 0.0.0-20250212165942-faa3f617eef5 |
| `github.com/linkerd/linkerd2` | Go | All versions | 0.0.0-20250212165942-faa3f617eef5 |
| `govulncheck-vulndb` | openSUSE:Tumbleweed | All versions | 0.0.20250520T172319-1.1 |

Products: Linkerd Buoyant, Linkerd Linkerd.

## How do I fix CVE-2025-43915?

Upgrade github.com/linkerd/linkerd2 to 0.0.0-20250212165942-faa3f617eef5 or later.

## Is CVE-2025-43915 being exploited?

There is no known exploitation of CVE-2025-43915 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43915 and fix it if it is affected.

What it is: CVE-2025-43915 is a medium-severity denial of service vulnerability in n/a, published on 5 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43915 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/linkerd/linkerd2 (Go): affected all versions; no fix listed
- github.com/linkerd/linkerd2 (Go): affected all versions; fixed in 0.0.0-20250212165942-faa3f617eef5
- github.com/linkerd/linkerd2 (Go): affected all versions; fixed in 0.0.0-20250212165942-faa3f617eef5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43915/ (Markdown: https://insights.sbomify.com/CVE-2025-43915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43915
- OSV: https://osv.dev/vulnerability/CVE-2025-43915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43915/
Summaries are generated and may contain mistakes; the official description above is the record.
