# CVE-2025-43954: QMarkdown Cross-Site Scripting (XSS) vulnerability

> Attackers can execute arbitrary scripts via headers in QMarkdown even when no-html is enabled, affecting Quasar applications.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2025
- **Updated:** 21 Apr 2025
- **Also known as:** GHSA-wm65-ph3w-587c

## What is CVE-2025-43954?

CVE-2025-43954 is a medium-severity cross-site scripting vulnerability in Quasar QMarkdown, published on 20 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

QMarkdown (aka quasar-ui-qmarkdown) before 2.0.5 allows XSS via headers even when when no-html is set.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-43954?

2 open source packages ship an affected version, including @quasar/quasar-ui-qmarkdown. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@quasar/quasar-ui-qmarkdown` | npm | All versions | 2.0.5 |
| `@quasar/quasar-ui-qmarkdown` | npm | All versions | 2.0.5 |

Products: Quasar Qmarkdown.

## How do I fix CVE-2025-43954?

Upgrade @quasar/quasar-ui-qmarkdown to 2.0.5 or later.

## Is CVE-2025-43954 being exploited?

There is no known exploitation of CVE-2025-43954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43954 and fix it if it is affected.

What it is: CVE-2025-43954 is a medium-severity cross-site scripting vulnerability in Quasar QMarkdown, published on 20 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43954 in the wild and no public exploit code.

Affected packages and fixed versions:
- @quasar/quasar-ui-qmarkdown (npm): affected all versions; fixed in 2.0.5
- @quasar/quasar-ui-qmarkdown (npm): affected all versions; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43954/ (Markdown: https://insights.sbomify.com/CVE-2025-43954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43954
- OSV: https://osv.dev/vulnerability/CVE-2025-43954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43954/
Summaries are generated and may contain mistakes; the official description above is the record.
