{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-43965 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-43965 is a low-severity vulnerability in Debian Debian Linux, published on 23 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-43965 and fix it if it is affected.\n\nWhat it is: CVE-2025-43965 is a low-severity vulnerability in Debian Debian Linux, published on 23 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-43965 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-43965/ (Markdown: https://insights.sbomify.com/CVE-2025-43965/index.md)","id":"CVE-2025-43965","markdown":"https://insights.sbomify.com/CVE-2025-43965/index.md","name":"CVE-2025-43965","record":{"aliases":["CLSA-2026-1783970505","CLSA-2026-1784037878","CLSA-2026-1784126490","CLSA-2026-1784126697","CLSA-2026-1784131324","DEBIAN-CVE-2025-43965","DLA-4139-1","GHSA-5qr3-hm6r-fwx9","JLSEC-2026-914","OESA-2025-1499","SUSE-SU-2025:1489-1","UBUNTU-CVE-2025-43965"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ImageMagick library","requires_auth":"none","summary":"An integer overflow in ImageMagick's MIFF processing allows attackers to cause denial of service or potentially execute code via crafted images.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"imagemagick","vendor":"imagemagick"}],"cvss":{"score":2.9,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"}],"description":"In MIFF image processing in ImageMagick before 7.1.1-44, image depth is mishandled after SetQuantumFormat is used.","ecosystems":["SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in ImageMagick","id":"CVE-2025-43965","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","imagemagick:imagemagick"],"type":"integer_overflow","year":"2025"},"n_packages":1,"n_references":2,"next":{"headline":"Null dereference in libheif","id":"CVE-2025-43966"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["6.8.8.1-71.204.1"],"introduced":["0"],"last_affected":[],"package":"ImageMagick","purl":"pkg:rpm/suse/ImageMagick\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2025:1489-1"}],"prev":{"headline":"Integer overflow in LibRaw","id":"CVE-2025-43964"},"products":["ImageMagick"],"published":"2025-04-23","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-26","vendors":["ImageMagick"]},"summary":"An integer overflow in ImageMagick's MIFF processing allows attackers to cause denial of service or potentially execute code via crafted images.","url":"https://insights.sbomify.com/CVE-2025-43965/"}