# CVE-2025-43970: GoBGP does not properly check the input length

> Attackers can cause a denial of service in GoBGP by sending malformed MRT packets with incorrect length fields.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2025
- **Updated:** 21 Apr 2025
- **Also known as:** CLEANSTART-2025-IS89195, DEBIAN-CVE-2025-43970, GHSA-hqhq-hp5x-xp3w, GO-2025-3630, MINI-3572-83g8-85f4, MINI-4pp7-mq35-pq2j, UBUNTU-CVE-2025-43970

## What is CVE-2025-43970?

CVE-2025-43970 is a medium-severity denial of service vulnerability in GoBGP, published on 21 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in GoBGP before 3.35.0. pkg/packet/mrt/mrt.go does not properly check the input length, e.g., by ensuring that there are 12 bytes or 36 bytes (depending on the address family).

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2025-43970?

6 open source packages ship an affected version, including github.com/osrg/gobgp and github.com/osrg/gobgp/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp` | Go | All versions | None |
| `github.com/osrg/gobgp` | Go | All versions | None |
| `github.com/osrg/gobgp` | Go | All versions | None |
| `github.com/osrg/gobgp/v3` | Go | All versions | 3.35.0 |
| `github.com/osrg/gobgp/v3` | Go | All versions | 3.35.0 |
| `github.com/osrg/gobgp/v3` | Go | All versions | 3.35.0 |

Products: Osrg Gobgp.

## How do I fix CVE-2025-43970?

Upgrade to a fixed version.

## Is CVE-2025-43970 being exploited?

There is no known exploitation of CVE-2025-43970 in the wild and no public exploit code.

## Other vulnerabilities in GoBGP

- [CVE-2025-43971](https://insights.sbomify.com/CVE-2025-43971/): GoBGP panics due to a zero value for softwareVersionLen (high 8.6)
- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-41643](https://insights.sbomify.com/CVE-2026-41643/): GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE (high 7.5)
- [CVE-2026-42285](https://insights.sbomify.com/CVE-2026-42285/): GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) (high 7.5)
- [CVE-2026-37461](https://insights.sbomify.com/CVE-2026-37461/): GoBGP has an out-of-bounds read in the ParseIP6Extended function (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43970 and fix it if it is affected.

What it is: CVE-2025-43970 is a medium-severity denial of service vulnerability in GoBGP, published on 21 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43970 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/osrg/gobgp (Go): affected all versions; no fix listed
- github.com/osrg/gobgp (Go): affected all versions; no fix listed
- github.com/osrg/gobgp (Go): affected all versions; no fix listed
- github.com/osrg/gobgp/v3 (Go): affected all versions; fixed in 3.35.0
- github.com/osrg/gobgp/v3 (Go): affected all versions; fixed in 3.35.0
- github.com/osrg/gobgp/v3 (Go): affected all versions; fixed in 3.35.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43970/ (Markdown: https://insights.sbomify.com/CVE-2025-43970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43970
- OSV: https://osv.dev/vulnerability/CVE-2025-43970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43970/
Summaries are generated and may contain mistakes; the official description above is the record.
