{"answers":{"affected":"4 open source packages ship an affected version, including github.com/osrg/gobgp/v3 and github.com/osrg/gobgp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-43971 in the wild and no public exploit code.","fix":"Upgrade github.com/osrg/gobgp/v3 to 3.35.0 or later.","what":"CVE-2025-43971 is a high-severity denial of service vulnerability in GoBGP, published on 21 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-43971 and fix it if it is affected.\n\nWhat it is: CVE-2025-43971 is a high-severity denial of service vulnerability in GoBGP, published on 21 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-43971 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/osrg/gobgp/v3 (Go): affected all versions; fixed in 3.35.0\n- github.com/osrg/gobgp/v3 (Go): affected from 3.11.0; fixed in 3.35.0\n- github.com/osrg/gobgp/v3 (Go): affected from 3.11.0; fixed in 3.35.0\n- github.com/osrg/gobgp (Go): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-43971/ (Markdown: https://insights.sbomify.com/CVE-2025-43971/index.md)","id":"CVE-2025-43971","markdown":"https://insights.sbomify.com/CVE-2025-43971/index.md","name":"CVE-2025-43971","record":{"aliases":["DEBIAN-CVE-2025-43971","GHSA-7m35-vw2c-696v","GO-2025-3631","MINI-745c-j377-9f93","MINI-ccww-7cv5-x3g4","UBUNTU-CVE-2025-43971"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"BGP routing software","requires_auth":"none","summary":"Attackers can cause a panic in GoBGP by sending a BGP packet with a zero softwareVersionLen, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gobgp","vendor":"osrg"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-193","name":"Off-by-one Error"}],"description":"An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GoBGP panics due to a zero value for softwareVersionLen","id":"CVE-2025-43971","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"GoBGP crashes in the flowspec parser","id":"CVE-2025-43972"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp","purl":"pkg:golang/github.com/osrg/gobgp","source":"GO-2025-3631"},{"ecosystem":"Go","fixed":["3.35.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v3","purl":"pkg:golang/github.com/osrg/gobgp/v3","source":"GO-2025-3631"},{"ecosystem":"Go","fixed":["3.35.0"],"introduced":["3.11.0"],"last_affected":[],"package":"github.com/osrg/gobgp/v3","purl":null,"source":"GHSA-7m35-vw2c-696v"},{"ecosystem":"Go","fixed":["3.35.0"],"introduced":["3.11.0"],"last_affected":[],"package":"github.com/osrg/gobgp/v3","purl":"pkg:golang/github.com/osrg/gobgp/v3","source":"GHSA-7m35-vw2c-696v"}],"prev":{"headline":"GoBGP does not properly check the input length","id":"CVE-2025-43970"},"products":["GoBGP"],"published":"2025-04-21","related":[{"cvss_score":7.5,"headline":"GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute","id":"CVE-2026-41642","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE","id":"CVE-2026-41643","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference)","id":"CVE-2026-42285","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"GoBGP has an out-of-bounds read in the ParseIP6Extended function","id":"CVE-2026-37461","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute","id":"CVE-2026-30405","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":6.9,"headline":"osrg GoBGP SRv6 L3 Service prefix_sid.go SRv6L3ServiceAttribute.DecodeFromBytes denial of service","id":"CVE-2026-7734","kev_date_added":null,"published":"2026-05-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["GoBGP"]},"summary":"Attackers can cause a panic in GoBGP by sending a BGP packet with a zero softwareVersionLen, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2025-43971/"}