# CVE-2025-43971: GoBGP panics due to a zero value for softwareVersionLen

> Attackers can cause a panic in GoBGP by sending a BGP packet with a zero softwareVersionLen, leading to denial of service.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2025
- **Updated:** 21 Apr 2025
- **Also known as:** DEBIAN-CVE-2025-43971, GHSA-7m35-vw2c-696v, GO-2025-3631, MINI-745c-j377-9f93, MINI-ccww-7cv5-x3g4, UBUNTU-CVE-2025-43971

## What is CVE-2025-43971?

CVE-2025-43971 is a high-severity denial of service vulnerability in GoBGP, published on 21 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in GoBGP before 3.35.0. pkg/packet/bgp/bgp.go allows attackers to cause a panic via a zero value for softwareVersionLen.

Weakness: CWE-193 (Off-by-one Error)

## Which versions are affected by CVE-2025-43971?

4 open source packages ship an affected version, including github.com/osrg/gobgp/v3 and github.com/osrg/gobgp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v3` | Go | All versions | 3.35.0 |
| `github.com/osrg/gobgp/v3` | Go | From 3.11.0 | 3.35.0 |
| `github.com/osrg/gobgp/v3` | Go | From 3.11.0 | 3.35.0 |
| `github.com/osrg/gobgp` | Go | All versions | None |

Products: Osrg Gobgp.

## How do I fix CVE-2025-43971?

Upgrade github.com/osrg/gobgp/v3 to 3.35.0 or later.

## Is CVE-2025-43971 being exploited?

There is no known exploitation of CVE-2025-43971 in the wild and no public exploit code.

## Other vulnerabilities in GoBGP

- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-41643](https://insights.sbomify.com/CVE-2026-41643/): GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE (high 7.5)
- [CVE-2026-42285](https://insights.sbomify.com/CVE-2026-42285/): GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) (high 7.5)
- [CVE-2026-37461](https://insights.sbomify.com/CVE-2026-37461/): GoBGP has an out-of-bounds read in the ParseIP6Extended function (high 7.5)
- [CVE-2026-30405](https://insights.sbomify.com/CVE-2026-30405/): GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43971 and fix it if it is affected.

What it is: CVE-2025-43971 is a high-severity denial of service vulnerability in GoBGP, published on 21 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43971 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v3 (Go): affected all versions; fixed in 3.35.0
- github.com/osrg/gobgp/v3 (Go): affected from 3.11.0; fixed in 3.35.0
- github.com/osrg/gobgp/v3 (Go): affected from 3.11.0; fixed in 3.35.0
- github.com/osrg/gobgp (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43971/ (Markdown: https://insights.sbomify.com/CVE-2025-43971/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43971
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43971
- OSV: https://osv.dev/vulnerability/CVE-2025-43971

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43971/
Summaries are generated and may contain mistakes; the official description above is the record.
