# CVE-2025-44001: Unauthorized Channel Subscription Read in Mattermost Confluence Plugin

> Attackers can read channel subscription details without proper access via an API call in the Mattermost Confluence Plugin.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** GHSA-vpcr-fqpc-386h, GO-2025-3863

## What is CVE-2025-44001?

CVE-2025-44001 is a medium-severity missing authorization vulnerability in Mattermost Confluence Plugin, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mattermost Confluence Plugin version <1.5.0 fails to check the access of the user to the channel which allows attackers to get channel subscription details without proper access to the channel via API call to the Get Channel Subscriptions details endpoint.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-44001?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-confluence. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-confluence` | Go | All versions | 1.5.0 |
| `github.com/mattermost/mattermost-plugin-confluence` | Go | All versions | 1.5.0 |
| `github.com/mattermost/mattermost-plugin-confluence` | Go | All versions | 1.5.0 |

Products: Mattermost Confluence.

## How do I fix CVE-2025-44001?

Upgrade github.com/mattermost/mattermost-plugin-confluence to 1.5.0 or later.

## Is CVE-2025-44001 being exploited?

There is no known exploitation of CVE-2025-44001 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Confluence Plugin

- [CVE-2025-13523](https://insights.sbomify.com/CVE-2025-13523/): Cross-Site Scripting (XSS) via Unescaped Display Names in Mattermost Confluence Plugin OAuth2 Flow (high 7.7)
- [CVE-2025-52931](https://insights.sbomify.com/CVE-2025-52931/): Unexpected input to Update Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin (high 7.5)
- [CVE-2025-54525](https://insights.sbomify.com/CVE-2025-54525/): Unexpected input to Create Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin (high 7.5)
- [CVE-2025-44004](https://insights.sbomify.com/CVE-2025-44004/): Unauthenticated Channel Subscription Creation in Mattermost Confluence Plugin (high 7.2)
- [CVE-2025-54478](https://insights.sbomify.com/CVE-2025-54478/): Unauthenticated Channel Subscription Edit in Mattermost Confluence Plugin (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-44001 and fix it if it is affected.

What it is: CVE-2025-44001 is a medium-severity missing authorization vulnerability in Mattermost Confluence Plugin, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-44001 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0
- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0
- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-44001/ (Markdown: https://insights.sbomify.com/CVE-2025-44001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-44001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-44001
- OSV: https://osv.dev/vulnerability/CVE-2025-44001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-44001/
Summaries are generated and may contain mistakes; the official description above is the record.
