{"answers":{"affected":"3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-confluence. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-44004 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-plugin-confluence to 1.5.0 or later.","what":"CVE-2025-44004 is a high-severity missing authorization vulnerability in Mattermost Confluence Plugin, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-44004 and fix it if it is affected.\n\nWhat it is: CVE-2025-44004 is a high-severity missing authorization vulnerability in Mattermost Confluence Plugin, published on 11 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-44004 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0\n- github.com/mattermost/mattermost-plugin-confluence (Go): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-44004/ (Markdown: https://insights.sbomify.com/CVE-2025-44004/index.md)","id":"CVE-2025-44004","markdown":"https://insights.sbomify.com/CVE-2025-44004/index.md","name":"CVE-2025-44004","record":{"aliases":["GHSA-6ff3-jgxh-vffj","GO-2025-3865"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Confluence Plugin","requires_auth":"none","summary":"Attackers can create channel subscriptions without authorization via API calls, requiring users to upgrade the Mattermost Confluence Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mattermost","cpe":[{"product":"confluence","vendor":"mattermost"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"}],"description":"Mattermost Confluence Plugin version \u003c1.5.0 fails to check the authorization of the user to the Mattermost instance which allows attackers to create a channel subscription without proper authorization via API call to the create channel subscription endpoint.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unauthenticated Channel Subscription Creation in Mattermost Confluence Plugin","id":"CVE-2025-44004","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Step CA Has Authorization Bypass in ACME and SCEP Provisioners","id":"CVE-2025-44005"},"packages":[{"ecosystem":"Go","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":null,"source":"GHSA-6ff3-jgxh-vffj"},{"ecosystem":"Go","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-confluence","source":"GHSA-6ff3-jgxh-vffj"},{"ecosystem":"Go","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-plugin-confluence","purl":"pkg:golang/github.com/mattermost/mattermost-plugin-confluence","source":"GO-2025-3865"}],"prev":{"headline":"Denial of service in T-Series Readers","id":"CVE-2025-44003"},"products":["Mattermost Confluence Plugin"],"published":"2025-08-11","related":[{"cvss_score":7.7,"headline":"Cross-Site Scripting (XSS) via Unescaped Display Names in Mattermost Confluence Plugin OAuth2 Flow","id":"CVE-2025-13523","kev_date_added":null,"published":"2026-02-06"},{"cvss_score":7.5,"headline":"Unexpected input to Update Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-52931","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.5,"headline":"Unexpected input to Create Channel Subscription endpoint causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-54525","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":7.2,"headline":"Unauthenticated Channel Subscription Edit in Mattermost Confluence Plugin","id":"CVE-2025-54478","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":6.4,"headline":"Unauthorized Subscription Edit to Confluence Space in Mattermost Confluence Plugin","id":"CVE-2025-48731","kev_date_added":null,"published":"2025-08-11"},{"cvss_score":5.9,"headline":"Unexpected Input to Server Webhook endpoint Causes DoS in Mattermost Confluence Plugin","id":"CVE-2025-53514","kev_date_added":null,"published":"2025-08-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-11","vendors":["Mattermost"]},"summary":"Attackers can create channel subscriptions without authorization via API calls, requiring users to upgrade the Mattermost Confluence Plugin.","url":"https://insights.sbomify.com/CVE-2025-44004/"}