# CVE-2025-44005: Step CA Has Authorization Bypass in ACME and SCEP Provisioners

> Attackers can bypass authorization checks to force Step CA to issue certificates without completing required protocol validations.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 17 Dec 2025
- **Also known as:** CLEANSTART-2026-ZH50133, CLEANSTART-2026-ZR04706, GHSA-h8cp-697h-8c8p, GO-2025-4180, MINI-3262-qw8f-6w4w

## What is CVE-2025-44005?

CVE-2025-44005 is a critical authentication bypass vulnerability in smallstep Step-CA, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An attacker can bypass authorization checks and force a Step CA ACME or SCEP provisioner to create certificates without completing certain protocol authorization checks.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-44005?

3 open source packages ship an affected version, including github.com/smallstep/certificates.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/smallstep/certificates` | Go | All versions | 0.29.0 |
| `github.com/smallstep/certificates` | Go | All versions | 0.29.0 |
| `github.com/smallstep/certificates` | Go | All versions | 0.29.0 |

## How do I fix CVE-2025-44005?

Upgrade github.com/smallstep/certificates to 0.29.0 or later.

## Is CVE-2025-44005 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-44005 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-44005 and fix it if it is affected.

What it is: CVE-2025-44005 is a critical authentication bypass vulnerability in smallstep Step-CA, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-44005 exists.

Affected packages and fixed versions:
- github.com/smallstep/certificates (Go): affected all versions; fixed in 0.29.0
- github.com/smallstep/certificates (Go): affected all versions; fixed in 0.29.0
- github.com/smallstep/certificates (Go): affected all versions; fixed in 0.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-44005/ (Markdown: https://insights.sbomify.com/CVE-2025-44005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-44005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-44005
- OSV: https://osv.dev/vulnerability/CVE-2025-44005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-44005/
Summaries are generated and may contain mistakes; the official description above is the record.
