CVE-2025-44021 OpenStack Ironic fails to restrict paths used for file:// image URLs

Low 2.8 Published Updated

A malicious project owner can write arbitrary local files to a target node disk via path traversal during image handling in OpenStack Ironic.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-44021?

CVE-2025-44021 is a low-severity path traversal vulnerability in OpenStack Ironic, published on 8 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.

Weakness: CWE-22

Which versions are affected by CVE-2025-44021?

7 open source packages ship an affected version, including ironic.

PackageAffectedFixed in
ironic PyPIAll versions24.1.3, 26.1.1, 29.0.1
ironic PyPIAll versions24.1.3
ironic PyPIAll versions24.1.3
ironic PyPIFrom 25.0.026.1.1
ironic PyPIFrom 25.0.026.1.1
ironic PyPIFrom 27.0.029.0.1
1 more packages
ironic PyPIFrom 27.0.029.0.1

How do I fix CVE-2025-44021?

Upgrade ironic to a fixed version for your release line: 24.1.3, 26.1.1 or 29.0.1.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2025-44021 being exploited?

There is no known exploitation of CVE-2025-44021 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-44021, GHSA-q3m2-crgq-5p3q, PYSEC-2025-38, UBUNTU-CVE-2025-44021.

Is CVE-2025-44021 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free