# CVE-2025-44021: OpenStack Ironic fails to restrict paths used for file:// image URLs

> A malicious project owner can write arbitrary local files to a target node disk via path traversal during image handling in OpenStack Ironic.

- **Severity:** Low 2.8 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2025
- **Updated:** 8 May 2025
- **Also known as:** DEBIAN-CVE-2025-44021, GHSA-q3m2-crgq-5p3q, PYSEC-2025-38, UBUNTU-CVE-2025-44021

## What is CVE-2025-44021?

CVE-2025-44021 is a low-severity path traversal vulnerability in OpenStack Ironic, published on 8 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenStack Ironic before 29.0.1 can write unintended files to a target node disk during image handling (if a deployment was performed via the API). A malicious project assigned as a node owner can provide a path to any local file (readable by ironic-conductor), which may then be written to the target node disk. This is difficult to exploit in practice, because a node deployed in this manner should never reach the ACTIVE state, but it still represents a danger in environments running with non-default, insecure configurations such as with automated cleaning disabled. The fixed versions are 24.1.3, 26.1.1, and 29.0.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-44021?

7 open source packages ship an affected version, including ironic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic` | PyPI | All versions | 24.1.3, 26.1.1, 29.0.1 |
| `ironic` | PyPI | All versions | 24.1.3 |
| `ironic` | PyPI | All versions | 24.1.3 |
| `ironic` | PyPI | From 25.0.0 | 26.1.1 |
| `ironic` | PyPI | From 25.0.0 | 26.1.1 |
| `ironic` | PyPI | From 27.0.0 | 29.0.1 |
| `ironic` | PyPI | From 27.0.0 | 29.0.1 |

## How do I fix CVE-2025-44021?

Upgrade ironic to a fixed version for your release line: 24.1.3, 26.1.1 or 29.0.1.

## Is CVE-2025-44021 being exploited?

There is no known exploitation of CVE-2025-44021 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-44021 and fix it if it is affected.

What it is: CVE-2025-44021 is a low-severity path traversal vulnerability in OpenStack Ironic, published on 8 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-44021 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic (PyPI): affected all versions; fixed in 24.1.3, 26.1.1, 29.0.1
- ironic (PyPI): affected all versions; fixed in 24.1.3
- ironic (PyPI): affected all versions; fixed in 24.1.3
- ironic (PyPI): affected from 25.0.0; fixed in 26.1.1
- ironic (PyPI): affected from 25.0.0; fixed in 26.1.1
- ironic (PyPI): affected from 27.0.0; fixed in 29.0.1
- ironic (PyPI): affected from 27.0.0; fixed in 29.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-44021/ (Markdown: https://insights.sbomify.com/CVE-2025-44021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-44021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-44021
- OSV: https://osv.dev/vulnerability/CVE-2025-44021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-44021/
Summaries are generated and may contain mistakes; the official description above is the record.
