{"answers":{"affected":"2 open source packages ship an affected version, including billz/raspap-webgui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-44163 exists.","fix":"Upgrade billz/raspap-webgui to 3.3.6 or later.","what":"CVE-2025-44163 is a medium-severity path traversal vulnerability in n/a, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-44163 and fix it if it is affected.\n\nWhat it is: CVE-2025-44163 is a medium-severity path traversal vulnerability in n/a, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-44163 exists.\n\nAffected packages and fixed versions:\n- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.3.6\n- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-44163/ (Markdown: https://insights.sbomify.com/CVE-2025-44163/index.md)","id":"CVE-2025-44163","markdown":"https://insights.sbomify.com/CVE-2025-44163/index.md","name":"CVE-2025-44163","record":{"aliases":["GHSA-277f-37gw-9gmq"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"RaspAP web interface","requires_auth":"none","summary":"An authenticated attacker can exploit a path traversal vulnerability in RaspAP to overwrite arbitrary files, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"raspap-webgui","vendor":"raspap"}],"cvss":{"score":6.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the `entity` parameter to overwrite arbitrary files writable by the web server via abuse of the `tee` command used in shell execution.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"raspap-webgui has a Directory Traversal vulnerability","id":"CVE-2025-44163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2025-44172"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.6"],"introduced":["0"],"last_affected":[],"package":"billz/raspap-webgui","purl":null,"source":"GHSA-277f-37gw-9gmq"},{"ecosystem":"Packagist","fixed":["3.3.6"],"introduced":["0"],"last_affected":[],"package":"billz/raspap-webgui","purl":"pkg:composer/billz/raspap-webgui","source":"GHSA-277f-37gw-9gmq"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2025-44148"},"products":["n/a"],"published":"2025-06-27","related":[{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2025-50428","kev_date_added":null,"published":"2025-08-27"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2024-36622","kev_date_added":null,"published":"2024-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-27","vendors":["n/a"]},"summary":"An authenticated attacker can exploit a path traversal vulnerability in RaspAP to overwrite arbitrary files, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2025-44163/"}