# CVE-2025-44163: raspap-webgui has a Directory Traversal vulnerability

> An authenticated attacker can exploit a path traversal vulnerability in RaspAP to overwrite arbitrary files, potentially leading to code execution.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jun 2025
- **Updated:** 27 Jun 2025
- **Also known as:** GHSA-277f-37gw-9gmq

## What is CVE-2025-44163?

CVE-2025-44163 is a medium-severity path traversal vulnerability in n/a, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/get_wgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the `entity` parameter to overwrite arbitrary files writable by the web server via abuse of the `tee` command used in shell execution.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2025-44163?

2 open source packages ship an affected version, including billz/raspap-webgui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `billz/raspap-webgui` | Packagist | All versions | 3.3.6 |
| `billz/raspap-webgui` | Packagist | All versions | 3.3.6 |

Products: Raspap Raspap-Webgui.

## How do I fix CVE-2025-44163?

Upgrade billz/raspap-webgui to 3.3.6 or later.

## Is CVE-2025-44163 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-44163 exists.

## Other vulnerabilities in n/a

- [CVE-2025-50428](https://insights.sbomify.com/CVE-2025-50428/): Command injection in n/a (critical 9.8)
- [CVE-2024-36622](https://insights.sbomify.com/CVE-2024-36622/): Command injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-44163 and fix it if it is affected.

What it is: CVE-2025-44163 is a medium-severity path traversal vulnerability in n/a, published on 27 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-44163 exists.

Affected packages and fixed versions:
- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.3.6
- billz/raspap-webgui (Packagist): affected all versions; fixed in 3.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-44163/ (Markdown: https://insights.sbomify.com/CVE-2025-44163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-44163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-44163
- OSV: https://osv.dev/vulnerability/CVE-2025-44163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-44163/
Summaries are generated and may contain mistakes; the official description above is the record.
