CVE-2025-4439 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 7.7 Published Updated

Authenticated users can execute cross-site scripting attacks in GitLab when served through specific content delivery networks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-4439?

CVE-2025-4439 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed an authenticated user to perform cross-site scripting attacks when the instance is served through certain content delivery networks.

Weakness: CWE-79

Which versions are affected by CVE-2025-4439?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.10.018.0.5, 18.1.3, 18.2.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-4439?

Upgrade gitlab to a fixed version for your release line: 18.0.5, 18.1.3 or 18.2.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-4439 being exploited?

There is no known exploitation of CVE-2025-4439 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-4439, GHSA-2r7r-6rh2-7qc9, UBUNTU-CVE-2025-4439.

Is CVE-2025-4439 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free