# CVE-2025-4439: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

> Authenticated users can execute cross-site scripting attacks in GitLab when served through specific content delivery networks.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-gitlab-2025-4439, GHSA-2r7r-6rh2-7qc9, UBUNTU-CVE-2025-4439

## What is CVE-2025-4439?

CVE-2025-4439 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 before 18.0.5, 18.1 before 18.1.3, and 18.2 before 18.2.1 that could have allowed an authenticated user to perform cross-site scripting attacks when the instance is served through certain content delivery networks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-4439?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 15.10.0 | 18.0.5, 18.1.3, 18.2.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-4439?

Upgrade gitlab to a fixed version for your release line: 18.0.5, 18.1.3 or 18.2.1.

## Is CVE-2025-4439 being exploited?

There is no known exploitation of CVE-2025-4439 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4439 and fix it if it is affected.

What it is: CVE-2025-4439 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4439 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 15.10.0; fixed in 18.0.5, 18.1.3, 18.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4439/ (Markdown: https://insights.sbomify.com/CVE-2025-4439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4439
- OSV: https://osv.dev/vulnerability/CVE-2025-4439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4439/
Summaries are generated and may contain mistakes; the official description above is the record.
