# CVE-2025-4517: Arbitrary writes via tarfile realpath overflow

> Attackers can write arbitrary files outside the extraction directory when extracting untrusted tar archives using specific filters in Python's tarfile module.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2025
- **Updated:** 4 Aug 2026
- **Also known as:** ALPINE-CVE-2025-4517, AZL-62307, AZL-62318, BELL-CVE-2025-4517, BIT-libpython-2025-4517, BIT-python-2025-4517, BIT-python-min-2025-4517, CLEANSTART-2026-CP22630, CLEANSTART-2026-NP36052, DEBIAN-CVE-2025-4517, ECHO-9cfa-3451-0e1e, GHSA-6r6c-684h-9j7p, MINI-3vq5-cmp2-rh3h, MINI-vjfr-qc3q-mpw4, MINI-vx3g-pp28-476g, MINI-xfh2-5gx8-2x38, PSF-2025-9, UBUNTU-CVE-2025-4517

## What is CVE-2025-4517?

CVE-2025-4517 is a critical path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allows arbitrary filesystem writes outside the extraction directory during extraction with filter="data".

You are affected by this vulnerability if using the tarfile module to extract untrusted tar archives using TarFile.extractall() or TarFile.extract() using the filter= parameter with a value of "data" or "tar". See the tarfile  extraction filters documentation https://docs.python.org/3/library/tarfile.html#tarfile-extraction-filter  for more information.

Note that for Python 3.14 or later the default value of filter= changed from "no filtering" to `"data", so if you are relying on this new default behavior then your usage is also affected.

Note that none of these vulnerabilities significantly affect the installation of source distributions which are tar archives as source distributions already allow arbitrary code execution during the build process. However when evaluating source distributions it's important to avoid installing source distributions with suspicious links.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-4517?

3 open source packages ship an affected version, including libpython, python and python-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4 |
| `python` | Bitnami | All versions | 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4 |
| `python-min` | Bitnami | All versions | 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4 |

## How do I fix CVE-2025-4517?

Upgrade libpython to a fixed version for your release line: 3.9.23, 3.10.18, 3.11.13 or 3.12.11.

## Is CVE-2025-4517 being exploited?

There is no known exploitation of CVE-2025-4517 in the wild and no public exploit code.

Public exploit code:

- Privilege Escalation script for CVE-2025-4517 (github_poc): https://github.com/AzureADTrent/CVE-2025-4517-POC
- Python tarfile data filter bypass via PATH_MAX overflow in os.path.realpath() - CVE-2025-4517 / CVE-2025-4330 (github_poc): https://github.com/0xDTC/CVE-2025-4517-tarfile-PATH_MAX-bypass
- CVE‑2025‑4517 Proof‑of‑Concept Script (github_poc): https://github.com/AnimePrincess420/CVE-2025-4517-PoC
- CVE-2025-4517  (CVSS 9.4 – Critical)   A vulnerability in Python's `tarfile`  (github_poc): https://github.com/StealthByte0/CVE-2025-4517-poc
- Path traversal vulnerability in Python's tarfile. (github_poc): https://github.com/estebanzarate/CVE-2025-4517-Python-tarfile-filter-data-Bypass-PoC
- A high-performance Python toolkit to automate the CVE-2025-4517 PATH_MAX bypass exploit. Specifically tuned for the WingData HTB challenge to achieve arbitrary file writes and root persistence (github_poc): https://github.com/Rohitberiwala/PyPath-Escape-CVE-2025-4517-Exploit-Research

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4517 and fix it if it is affected.

What it is: CVE-2025-4517 is a critical path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4517 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4
- python (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4
- python-min (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4517/ (Markdown: https://insights.sbomify.com/CVE-2025-4517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4517
- OSV: https://osv.dev/vulnerability/CVE-2025-4517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4517/
Summaries are generated and may contain mistakes; the official description above is the record.
