# CVE-2025-45346: Bacula-web SQL Injection Vulnerability

> Remote attackers can execute arbitrary code via SQL injection in Bacula-web, requiring an upgrade to secure the web interface.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jul 2025
- **Updated:** 29 Jul 2025
- **Also known as:** GHSA-hq25-vp56-qr86

## What is CVE-2025-45346?

CVE-2025-45346 is a high-severity SQL injection vulnerability in n/a, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL Injection vulnerability in Bacula-web before v.9.7.1 allows a remote attacker to execute arbitrary code via a crafted HTTP GET request.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-45346?

2 open source packages ship an affected version, including bacula-web/bacula-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bacula-web/bacula-web` | Packagist | All versions | 9.7.1 |
| `bacula-web/bacula-web` | Packagist | All versions | 9.7.1 |

Products: Bacula Bacula-Web.

## How do I fix CVE-2025-45346?

Upgrade bacula-web/bacula-web to 9.7.1 or later.

## Is CVE-2025-45346 being exploited?

There is no known exploitation of CVE-2025-45346 in the wild and no public exploit code.

Public exploit code:

- https://github.com/0xsu3ks/CVE-2025-45346 (github_poc): https://github.com/0xsu3ks/CVE-2025-45346

## Other vulnerabilities in n/a

- [CVE-2017-15367](https://insights.sbomify.com/CVE-2017-15367/): Bacula-web SQL Injection Vulnerabilities (critical 9.8)
- [CVE-2014-8295](https://insights.sbomify.com/CVE-2014-8295/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-45346 and fix it if it is affected.

What it is: CVE-2025-45346 is a high-severity SQL injection vulnerability in n/a, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-45346 in the wild and no public exploit code.

Affected packages and fixed versions:
- bacula-web/bacula-web (Packagist): affected all versions; fixed in 9.7.1
- bacula-web/bacula-web (Packagist): affected all versions; fixed in 9.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-45346/ (Markdown: https://insights.sbomify.com/CVE-2025-45346/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-45346
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-45346
- OSV: https://osv.dev/vulnerability/CVE-2025-45346

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-45346/
Summaries are generated and may contain mistakes; the official description above is the record.
