CVE-2025-4573 LDAP Injection in Mattermost Enterprise Edition When Using Active Directory
An authenticated administrator can inject LDAP search filters to bypass access controls or read data when objectGUID is configured as the Group ID Attribute.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-4573?
CVE-2025-4573 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 11 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.7.x <= 10.7.1, 10.6.x <= 10.6.3, 10.5.x <= 10.5.4, 9.11.x <= 9.11.13 fail to properly validate LDAP group ID attributes, allowing an authenticated administrator with PermissionSysconsoleWriteUserManagementGroups permission to execute LDAP search filter injection via the PUT /api/v4/ldap/groups/{remote_id}/link API when objectGUID is configured as the Group ID Attribute.
Weakness: CWE-90
Which versions are affected by CVE-2025-4573?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.5 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.5 |
github.com/mattermost/mattermost-server Go | From 10.6.0 | 10.6.4 |
github.com/mattermost/mattermost-server Go | From 10.6.0 | 10.6.4 |
github.com/mattermost/mattermost-server Go | From 10.7.0 | 10.7.2 |
github.com/mattermost/mattermost-server Go | From 10.7.0 | 10.7.2 |
8 more packages
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.14 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.14 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.14+incompatible, 10.5.5+incompatible, 10.6.4+incompatible, 10.7.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414112942-77892234944b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414112942-77892234944b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414112942-77892234944b |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-4573?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.5, 10.6.4, 10.7.2 or 9.11.14.
Is CVE-2025-4573 being exploited?
There is no known exploitation of CVE-2025-4573 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-4r67-4x4p-fprg, GO-2025-3756.