{"answers":{"affected":"2 open source packages ship an affected version, including firebase/php-jwt. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-45769 exists.","fix":"Upgrade firebase/php-jwt to 7.0.0 or later.","what":"CVE-2025-45769 is a medium-severity vulnerability in n/a, published on 31 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-45769 and fix it if it is affected.\n\nWhat it is: CVE-2025-45769 is a medium-severity vulnerability in n/a, published on 31 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-45769 exists.\n\nAffected packages and fixed versions:\n- firebase/php-jwt (Packagist): affected all versions; fixed in 7.0.0\n- firebase/php-jwt (Packagist): affected all versions; fixed in 7.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-45769/ (Markdown: https://insights.sbomify.com/CVE-2025-45769/index.md)","id":"CVE-2025-45769","markdown":"https://insights.sbomify.com/CVE-2025-45769/index.md","name":"CVE-2025-45769","record":{"aliases":["CLSA-2026-1769734644","CLSA-2026-1788348158","GHSA-2x45-7fc3-mxwq"],"analysis":{"component_type":"library","fix_type":"configuration_change","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP JWT library","requires_auth":"none","summary":"Weak encryption in php-jwt allows security bypass if applications configure insufficient key lengths, requiring developers to enforce strong cryptographic settings.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"firebase_php-jwt","vendor":"google"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-326","name":"Inadequate Encryption Strength"}],"description":"php-jwt v6.11.0 was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"php-jwt contains weak encryption","id":"CVE-2025-45769","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":2,"n_references":8,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2025-45770"},"packages":[{"ecosystem":"Packagist","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"firebase/php-jwt","purl":null,"source":"GHSA-2x45-7fc3-mxwq"},{"ecosystem":"Packagist","fixed":["7.0.0"],"introduced":["0"],"last_affected":[],"package":"firebase/php-jwt","purl":"pkg:composer/firebase/php-jwt","source":"GHSA-2x45-7fc3-mxwq"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2025-45768"},"products":["n/a"],"published":"2025-07-31","related":[{"cvss_score":9.1,"headline":"Firebase PHP-JWT key/algorithm type confusion","id":"CVE-2021-46743","kev_date_added":null,"published":"2022-03-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-18","vendors":["n/a"]},"summary":"Weak encryption in php-jwt allows security bypass if applications configure insufficient key lengths, requiring developers to enforce strong cryptographic settings.","url":"https://insights.sbomify.com/CVE-2025-45769/"}