# CVE-2025-45769: php-jwt contains weak encryption

> Weak encryption in php-jwt allows security bypass if applications configure insufficient key lengths, requiring developers to enforce strong cryptographic settings.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jul 2025
- **Updated:** 18 Feb 2026
- **Also known as:** CLSA-2026-1769734644, CLSA-2026-1788348158, GHSA-2x45-7fc3-mxwq

## What is CVE-2025-45769?

CVE-2025-45769 is a medium-severity vulnerability in n/a, published on 31 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

php-jwt v6.11.0 was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is not meant to recommend an outcome for this CVE Record.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2025-45769?

2 open source packages ship an affected version, including firebase/php-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `firebase/php-jwt` | Packagist | All versions | 7.0.0 |
| `firebase/php-jwt` | Packagist | All versions | 7.0.0 |

Products: Google Firebase Php-Jwt.

## How do I fix CVE-2025-45769?

Upgrade firebase/php-jwt to 7.0.0 or later.

## Is CVE-2025-45769 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-45769 exists.

## Other vulnerabilities in n/a

- [CVE-2021-46743](https://insights.sbomify.com/CVE-2021-46743/): Firebase PHP-JWT key/algorithm type confusion (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-45769 and fix it if it is affected.

What it is: CVE-2025-45769 is a medium-severity vulnerability in n/a, published on 31 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-45769 exists.

Affected packages and fixed versions:
- firebase/php-jwt (Packagist): affected all versions; fixed in 7.0.0
- firebase/php-jwt (Packagist): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-45769/ (Markdown: https://insights.sbomify.com/CVE-2025-45769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-45769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-45769
- OSV: https://osv.dev/vulnerability/CVE-2025-45769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-45769/
Summaries are generated and may contain mistakes; the official description above is the record.
