# CVE-2025-4581: Liferay Portal and Liferay DXP vulnerable to Server-Side Request Forgery

> Pre-authentication blind SSRF in Liferay Portal allows attackers to force server requests to internal systems, enabling network enumeration and potential further exploitation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2025
- **Updated:** 11 Aug 2025
- **Also known as:** GHSA-6v93-frf9-2rp8

## What is CVE-2025-4581?

CVE-2025-4581 is a medium-severity server-side request forgery vulnerability in Liferay Digital Experience Platform, published on 9 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Liferay Portal 7.4.0 through 7.4.3.132, and Liferay DXP 2025.Q1.0 through 2025.Q1.4 ,2024.Q4.0 through 2024.Q4.7, 2024.Q3.1 through 2024.Q3.13, 2024.Q2.0 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.15, 7.4 GA through update 92 allows a pre-authentication blind SSRF vulnerability in the portal-settings-authentication-opensso-web due to improper validation of user-supplied URLs. An attacker can exploit this issue to force the server to make arbitrary HTTP requests to internal systems, potentially leading to internal network enumeration or further exploitation.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-4581?

14 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions to 7.4.13.u92 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | All versions to 7.4.13.u92 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q1.0 | 2024.Q1.16 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q1.0 | 2024.Q1.16 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q2.0 to 2024.Q2.13 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q2.0 to 2024.Q2.13 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q3.1 to 2024.Q3.13 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q3.1 to 2024.Q3.13 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q4.0 to 2024.Q4.7 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2024.Q4.0 to 2024.Q4.7 | None |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2025.Q1.0 | 2025.Q1.5 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 2025.Q1.0 | 2025.Q1.5 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.4.0 to 7.4.3.132 | None |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.4.0 to 7.4.3.132 | None |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-4581?

Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 2024.Q1.16 or 2025.Q1.5.

## Is CVE-2025-4581 being exploited?

There is no known exploitation of CVE-2025-4581 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4581 and fix it if it is affected.

What it is: CVE-2025-4581 is a medium-severity server-side request forgery vulnerability in Liferay Digital Experience Platform, published on 9 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4581 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected all versions up to 7.4.13.u92; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected all versions up to 7.4.13.u92; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q1.0; fixed in 2024.Q1.16
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q1.0; fixed in 2024.Q1.16
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q2.0 up to 2024.Q2.13; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q2.0 up to 2024.Q2.13; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q3.1 up to 2024.Q3.13; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q3.1 up to 2024.Q3.13; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q4.0 up to 2024.Q4.7; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2024.Q4.0 up to 2024.Q4.7; no fix listed
- com.liferay.portal:release.dxp.bom (Maven): affected from 2025.Q1.0; fixed in 2025.Q1.5
- com.liferay.portal:release.dxp.bom (Maven): affected from 2025.Q1.0; fixed in 2025.Q1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4581/ (Markdown: https://insights.sbomify.com/CVE-2025-4581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4581
- OSV: https://osv.dev/vulnerability/CVE-2025-4581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4581/
Summaries are generated and may contain mistakes; the official description above is the record.
