# CVE-2025-46096: Solon Vulnerable to Directory Traversal

> A remote attacker can exploit a directory traversal flaw in the solon-faas-luffy component to execute cross-site scripting attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2025
- **Updated:** 13 Jun 2025
- **Also known as:** GHSA-m63q-4hr8-5r5h

## What is CVE-2025-46096?

CVE-2025-46096 is a medium-severity path traversal vulnerability in n/a, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Directory Traversal vulnerability in solon v.3.1.2 allows a remote attacker to conduct XSS attacks via the solon-faas-luffy component

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-46096?

2 open source packages ship an affected version, including org.noear:solon-faas-luffy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.noear:solon-faas-luffy` | Maven | From 3.1.2 | 3.2.0 |
| `org.noear:solon-faas-luffy` | Maven | From 3.1.2 | 3.2.0 |

Products: Noear Solon.

## How do I fix CVE-2025-46096?

Upgrade org.noear:solon-faas-luffy to 3.2.0 or later.

## Is CVE-2025-46096 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46096 exists.

## Other vulnerabilities in n/a

- [CVE-2023-48967](https://insights.sbomify.com/CVE-2023-48967/): Solon is vulnerable to Deserialization of Untrusted Data (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46096 and fix it if it is affected.

What it is: CVE-2025-46096 is a medium-severity path traversal vulnerability in n/a, published on 13 Jun 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46096 exists.

Affected packages and fixed versions:
- org.noear:solon-faas-luffy (Maven): affected from 3.1.2; fixed in 3.2.0
- org.noear:solon-faas-luffy (Maven): affected from 3.1.2; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46096/ (Markdown: https://insights.sbomify.com/CVE-2025-46096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46096
- OSV: https://osv.dev/vulnerability/CVE-2025-46096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46096/
Summaries are generated and may contain mistakes; the official description above is the record.
