# CVE-2025-46152: Integer overflow in n/a

> Incorrect output in bitwise_right_shift for out-of-bounds values may lead to unexpected behavior in PyTorch applications.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2025
- **Updated:** 25 Sep 2025
- **Also known as:** AZL-67884, BIT-pytorch-2025-46152, DEBIAN-CVE-2025-46152, ECHO-5041-4532-d915, GHSA-x8x6-v465-7v88, PYSEC-2025-201, UBUNTU-CVE-2025-46152

## What is CVE-2025-46152?

CVE-2025-46152 is a medium-severity vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PyTorch before 2.7.0, bitwise_right_shift produces incorrect output for certain out-of-bounds values of the "other" argument.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2025-46152?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | From 2.6.0 | 2.7.0 |
| `torch` | PyPI | From 2.6.0 | 2.7.0 |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-46152?

Upgrade pytorch to 2.7.0 or later.

## Is CVE-2025-46152 being exploited?

There is no known exploitation of CVE-2025-46152 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46152 and fix it if it is affected.

What it is: CVE-2025-46152 is a medium-severity vulnerability in n/a, published on 25 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46152 in the wild and no public exploit code.

Affected packages and fixed versions:
- pytorch (Bitnami): affected from 2.6.0; fixed in 2.7.0
- torch (PyPI): affected from 2.6.0; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46152/ (Markdown: https://insights.sbomify.com/CVE-2025-46152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46152
- OSV: https://osv.dev/vulnerability/CVE-2025-46152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46152/
Summaries are generated and may contain mistakes; the official description above is the record.
