# CVE-2025-46328: NodeJS Driver for Snowflake has race condition when checking access to Easy Logging configuration file

> A local attacker can exploit a race condition in the Easy Logging feature to overwrite configuration files, potentially altering logging behavior and bypassing security checks.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-wmjq-jrm2-9wfr

## What is CVE-2025-46328?

CVE-2025-46328 is a low-severity vulnerability in snowflakedb snowflake-connector-nodejs, published on 28 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

snowflake-connector-nodejs is a NodeJS driver for Snowflake. Versions starting from 1.10.0 to before 2.0.4, are vulnerable to a Time-of-Check to Time-of-Use (TOCTOU) race condition. When using the Easy Logging feature on Linux and macOS the Driver reads logging configuration from a user-provided file. On Linux and macOS the Driver verifies that the configuration file can be written to only by its owner. That check was vulnerable to a TOCTOU race condition and failed to verify that the file owner matches the user running the Driver. This could allow a local attacker with write access to the configuration file or the directory containing it to overwrite the configuration and gain control over logging level and output location. This issue has been patched in version 2.0.4.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2025-46328?

2 open source packages ship an affected version, including snowflake-sdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-sdk` | npm | From 1.10.0 | 2.0.4 |
| `snowflake-sdk` | npm | From 1.10.0 | 2.0.4 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2025-46328?

Upgrade snowflake-sdk to 2.0.4 or later.

## Is CVE-2025-46328 being exploited?

There is no known exploitation of CVE-2025-46328 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-connector-nodejs

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2023-34233](https://insights.sbomify.com/CVE-2023-34233/): Snowflake Python Connector vulnerable to Command Injection (high 7.3)
- [CVE-2025-24793](https://insights.sbomify.com/CVE-2025-24793/): Snowflake Connector for Python has an SQL Injection in write_pandas (high 7.0)
- [CVE-2025-24794](https://insights.sbomify.com/CVE-2025-24794/): The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46328 and fix it if it is affected.

What it is: CVE-2025-46328 is a low-severity vulnerability in snowflakedb snowflake-connector-nodejs, published on 28 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46328 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-sdk (npm): affected from 1.10.0; fixed in 2.0.4
- snowflake-sdk (npm): affected from 1.10.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46328/ (Markdown: https://insights.sbomify.com/CVE-2025-46328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46328
- OSV: https://osv.dev/vulnerability/CVE-2025-46328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46328/
Summaries are generated and may contain mistakes; the official description above is the record.
