# CVE-2025-46329: Snowflake Connector for C/C++ inserts client-side encryption key in DEBUG logs

> Attackers with local access can read sensitive encryption keys from debug logs in the Snowflake C/C++ connector.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-jx4f-645p-wjpx

## What is CVE-2025-46329?

CVE-2025-46329 is a low-severity vulnerability in snowflakedb libsnowflakeclient, published on 29 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libsnowflakeclient is the Snowflake Connector for C/C++. Versions starting from 0.5.0 to before 2.2.0, are vulnerable to local logging of sensitive information. When the logging level was set to DEBUG, the Connector would log locally the client-side encryption master key of the target stage during the execution of GET/PUT commands. This key by itself does not grant access to any sensitive data without additional access authorizations, and is not logged server-side by Snowflake. This issue has been patched in version 2.2.0.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-46329?

It affects 1 product.


Products: Snowflake Connector for C\/C\+\+.

## How do I fix CVE-2025-46329?

No fix has been published for CVE-2025-46329 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-46329 being exploited?

There is no known exploitation of CVE-2025-46329 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb libsnowflakeclient

- [CVE-2025-46330](https://insights.sbomify.com/CVE-2025-46330/): Snowflake Connector for C/C++ retries malformed requests (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46329 and fix it if it is affected.

What it is: CVE-2025-46329 is a low-severity vulnerability in snowflakedb libsnowflakeclient, published on 29 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46329 in the wild and no public exploit code.

Affected product: snowflakedb libsnowflakeclient. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46329/ (Markdown: https://insights.sbomify.com/CVE-2025-46329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46329
- OSV: https://osv.dev/vulnerability/CVE-2025-46329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46329/
Summaries are generated and may contain mistakes; the official description above is the record.
