CVE-2025-46330 Snowflake Connector for C/C++ retries malformed requests

Low 3.3 Published Updated

Malformed requests cause the Snowflake C/C++ connector to retry excessively, hanging the application until the retry limit is reached.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-46330?

CVE-2025-46330 is a low-severity denial of service vulnerability in snowflakedb libsnowflakeclient, published on 29 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

libsnowflakeclient is the Snowflake Connector for C/C++. Versions starting from 0.5.0 to before 2.2.0, incorrectly treat malformed requests that caused the HTTP response status code 400, as able to be retried. This could hang the application until SF_CON_MAX_RETRY requests were sent. This issue has been patched in version 2.2.0.

Weakness: CWE-573

Which versions are affected by CVE-2025-46330?

It affects 1 product.

Products include Snowflake Connector for C\/C\+\+.

How do I fix CVE-2025-46330?

No fix has been published for CVE-2025-46330 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-46330 being exploited?

There is no known exploitation of CVE-2025-46330 in the wild and no public exploit code.

Sources

Also known as GHSA-ch37-53v3-m4cm.

Is CVE-2025-46330 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free