CVE-2025-46331 OpenFGA Authorization Bypass
Attackers can bypass authorization checks in OpenFGA, potentially gaining unauthorized access to protected resources.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-46331?
CVE-2025-46331 is a medium-severity authentication bypass vulnerability in openfga, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.8.10 to v1.3.6 (Helm chart <= openfga-0.2.28, docker <= v.1.8.10) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. This issue has been patched in version 1.8.11.
Weakness: CWE-284
Which versions are affected by CVE-2025-46331?
3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openfga/openfga Go | From 1.3.6 | 1.8.11 |
github.com/openfga/openfga Go | From 1.3.6 | 1.8.11 |
github.com/openfga/openfga Go | From 1.3.6 | 1.8.11 |
Products include Openfga Helm Charts, Openfga Openfga.
How do I fix CVE-2025-46331?
Upgrade github.com/openfga/openfga to 1.8.11 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-46331 being exploited?
There is no known exploitation of CVE-2025-46331 in the wild and no public exploit code.
Other vulnerabilities in openfga
Sources
Also known as GHSA-w222-m46c-mgh6, GO-2025-3657, MINI-c83f-559x-rcv4, MINI-ffxg-hh8w-fv4p, MINI-gc23-54g4-92q8.