{"answers":{"affected":"2 open source packages ship an affected version, including adodb/adodb-php.","exploited":"There is no known exploitation of CVE-2025-46337 in the wild and no public exploit code.","fix":"Upgrade adodb/adodb-php to 5.22.9 or later.","what":"CVE-2025-46337 is a critical SQL injection vulnerability in ADOdb, published on 1 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46337 and fix it if it is affected.\n\nWhat it is: CVE-2025-46337 is a critical SQL injection vulnerability in ADOdb, published on 1 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-46337 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- adodb/adodb-php (Packagist): affected all versions; fixed in 5.22.9\n- adodb/adodb-php (Packagist): affected all versions; fixed in 5.22.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46337/ (Markdown: https://insights.sbomify.com/CVE-2025-46337/index.md)","id":"CVE-2025-46337","markdown":"https://insights.sbomify.com/CVE-2025-46337/index.md","name":"CVE-2025-46337","record":{"aliases":["DEBIAN-CVE-2025-46337","DLA-4177-1","GHSA-8x27-jwjr-8545","MGASA-2025-0179","UBUNTU-CVE-2025-46337","USN-7530-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP database library","requires_auth":"none","summary":"Attackers can execute arbitrary SQL statements via the pg_insert_id method in ADOdb when connecting to PostgreSQL with user-supplied data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL injection in ADOdb PostgreSQL driver pg_insert_id() method","id":"CVE-2025-46337","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload","id":"CVE-2025-46338"},"packages":[{"ecosystem":"Packagist","fixed":["5.22.9"],"introduced":["0"],"last_affected":[],"package":"adodb/adodb-php","purl":null,"source":"GHSA-8x27-jwjr-8545"},{"ecosystem":"Packagist","fixed":["5.22.9"],"introduced":["0"],"last_affected":[],"package":"adodb/adodb-php","purl":"pkg:composer/adodb/adodb-php","source":"GHSA-8x27-jwjr-8545"}],"prev":{"headline":"Rack session gets restored after deletion","id":"CVE-2025-46336"},"products":["ADOdb"],"published":"2025-05-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-26","vendors":["ADOdb"]},"summary":"Attackers can execute arbitrary SQL statements via the pg_insert_id method in ADOdb when connecting to PostgreSQL with user-supplied data.","url":"https://insights.sbomify.com/CVE-2025-46337/"}