# CVE-2025-46337: SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

> Attackers can execute arbitrary SQL statements via the pg_insert_id method in ADOdb when connecting to PostgreSQL with user-supplied data.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2025
- **Updated:** 26 May 2025
- **Also known as:** DEBIAN-CVE-2025-46337, DLA-4177-1, GHSA-8x27-jwjr-8545, MGASA-2025-0179, UBUNTU-CVE-2025-46337, USN-7530-1

## What is CVE-2025-46337?

CVE-2025-46337 is a critical SQL injection vulnerability in ADOdb, published on 1 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-46337?

2 open source packages ship an affected version, including adodb/adodb-php.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adodb/adodb-php` | Packagist | All versions | 5.22.9 |
| `adodb/adodb-php` | Packagist | All versions | 5.22.9 |

## How do I fix CVE-2025-46337?

Upgrade adodb/adodb-php to 5.22.9 or later.

## Is CVE-2025-46337 being exploited?

There is no known exploitation of CVE-2025-46337 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46337 and fix it if it is affected.

What it is: CVE-2025-46337 is a critical SQL injection vulnerability in ADOdb, published on 1 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46337 in the wild and no public exploit code.

Affected packages and fixed versions:
- adodb/adodb-php (Packagist): affected all versions; fixed in 5.22.9
- adodb/adodb-php (Packagist): affected all versions; fixed in 5.22.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46337/ (Markdown: https://insights.sbomify.com/CVE-2025-46337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46337
- OSV: https://osv.dev/vulnerability/CVE-2025-46337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46337/
Summaries are generated and may contain mistakes; the official description above is the record.
