{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46338 exists.","fix":"No fix has been published for CVE-2025-46338 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-46338 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46338 and fix it if it is affected.\n\nWhat it is: CVE-2025-46338 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46338 exists.\n\nAffected product: advplyr audiobookshelf. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46338/ (Markdown: https://insights.sbomify.com/CVE-2025-46338/index.md)","id":"CVE-2025-46338","markdown":"https://insights.sbomify.com/CVE-2025-46338/index.md","name":"CVE-2025-46338","record":{"aliases":["GHSA-47g3-c5hx-2q3w"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Audiobookshelf server","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victims' browsers via reflected XSS in the upload API, requiring an upgrade to Audiobookshelf.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"audiobookshelf","vendor":"audiobookshelf"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload","id":"CVE-2025-46338","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"FreshRSS vulnerable to favicon cache poisoning via proxy","id":"CVE-2025-46339"},"packages":[],"prev":{"headline":"SQL injection in ADOdb PostgreSQL driver pg_insert_id() method","id":"CVE-2025-46337"},"products":["audiobookshelf"],"published":"2025-04-29","related":[{"cvss_score":8.8,"headline":"Audiobookshelf vulnerable to OIDC token exfiltration and account takeover","id":"CVE-2025-57800","kev_date_added":null,"published":"2025-08-22"},{"cvss_score":8.2,"headline":"Remote Authentication-Bypass can lead to server crash or limited information disclosure due to faulty pattern matching","id":"CVE-2025-25205","kev_date_added":null,"published":"2025-02-12"},{"cvss_score":8.1,"headline":"Audiobookshelf Server-Side Request Forgery and Arbitrary File Read Vulnerability","id":"CVE-2023-47619","kev_date_added":null,"published":"2023-12-13"},{"cvss_score":7.5,"headline":"Audiobookshelf Arbitrary File Read Vulnerability","id":"CVE-2023-47624","kev_date_added":null,"published":"2023-12-13"},{"cvss_score":6.3,"headline":"Path Traversal in audiobookshelf","id":"CVE-2024-43797","kev_date_added":null,"published":"2024-09-02"},{"cvss_score":4.8,"headline":"Audiobookshelf has Stored XSS in Tooltip.vue via Audiobook Metadata","id":"CVE-2026-27963","kev_date_added":null,"published":"2026-02-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["advplyr"]},"summary":"Attackers can execute arbitrary JavaScript in victims' browsers via reflected XSS in the upload API, requiring an upgrade to Audiobookshelf.","url":"https://insights.sbomify.com/CVE-2025-46338/"}