# CVE-2025-46338: Audiobookshelf Vulnerable to Cross-Site-Scripting Reflected via POST Request in /api/upload

> Attackers can execute arbitrary JavaScript in victims' browsers via reflected XSS in the upload API, requiring an upgrade to Audiobookshelf.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-47g3-c5hx-2q3w

## What is CVE-2025-46338?

CVE-2025-46338 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46338?

It affects 1 product.


Products: Audiobookshelf Audiobookshelf.

## How do I fix CVE-2025-46338?

No fix has been published for CVE-2025-46338 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-46338 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46338 exists.

## Other vulnerabilities in advplyr audiobookshelf

- [CVE-2025-57800](https://insights.sbomify.com/CVE-2025-57800/): Audiobookshelf vulnerable to OIDC token exfiltration and account takeover (high 8.8)
- [CVE-2025-25205](https://insights.sbomify.com/CVE-2025-25205/): Remote Authentication-Bypass can lead to server crash or limited information disclosure due to faulty pattern matching (high 8.2)
- [CVE-2023-47619](https://insights.sbomify.com/CVE-2023-47619/): Audiobookshelf Server-Side Request Forgery and Arbitrary File Read Vulnerability (high 8.1)
- [CVE-2023-47624](https://insights.sbomify.com/CVE-2023-47624/): Audiobookshelf Arbitrary File Read Vulnerability (high 7.5)
- [CVE-2024-43797](https://insights.sbomify.com/CVE-2024-43797/): Path Traversal in audiobookshelf (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46338 and fix it if it is affected.

What it is: CVE-2025-46338 is a medium-severity cross-site scripting vulnerability in advplyr audiobookshelf, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46338 exists.

Affected product: advplyr audiobookshelf. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46338/ (Markdown: https://insights.sbomify.com/CVE-2025-46338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46338
- OSV: https://osv.dev/vulnerability/CVE-2025-46338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46338/
Summaries are generated and may contain mistakes; the official description above is the record.
