# CVE-2025-46342: Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements

> Attackers with Kubernetes API access can bypass security policies by exploiting a logic error in namespace selector processing, allowing unauthorized operations.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-kyverno-2025-46342, CLEANSTART-2026-SI37771, CLEANSTART-2026-VJ98320, GHSA-jrr2-x33p-6hvc, GO-2025-3652, MINI-46pj-wj5h-xmgc, MINI-5c77-r4jp-pvv2, MINI-9mqv-m25r-4fj7, MINI-mmcp-6g5g-r2v6, MINI-phrf-9mhx-gx22

## What is CVE-2025-46342?

CVE-2025-46342 is a high-severity vulnerability in kyverno, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to versions 1.13.5 and 1.14.0, it may happen that policy rules using namespace selector(s) in their match statements are mistakenly not applied during admission review request processing due to a missing error propagation in function `GetNamespaceSelectorsFromNamespaceLister` in `pkg/utils/engine/labels.go`. As a consequence, security-critical mutations and validations are bypassed, potentially allowing attackers with K8s API access to perform malicious operations. This issue has been patched in versions 1.13.5 and 1.14.0.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2025-46342?

6 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.13.5, 1.14.0 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.13.5 |
| `github.com/kyverno/kyverno` | Go | All versions | 1.13.5 |
| `github.com/kyverno/kyverno` | Go | From 1.14.0-alpha.1 | 1.14.0 |
| `github.com/kyverno/kyverno` | Go | From 1.14.0-alpha.1 | 1.14.0 |
| `kyverno` | Bitnami | All versions | 1.13.5 |

Products: Kyverno Kyverno.

## How do I fix CVE-2025-46342?

Upgrade github.com/kyverno/kyverno to a fixed version for your release line: 1.13.5 or 1.14.0.

## Is CVE-2025-46342 being exploited?

There is no known exploitation of CVE-2025-46342 in the wild and no public exploit code.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)
- [CVE-2022-47633](https://insights.sbomify.com/CVE-2022-47633/): kyverno verifyImages rule bypass possible with malicious proxy/registry (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46342 and fix it if it is affected.

What it is: CVE-2025-46342 is a high-severity vulnerability in kyverno, published on 30 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46342 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.13.5, 1.14.0
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.13.5
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.13.5
- github.com/kyverno/kyverno (Go): affected from 1.14.0-alpha.1; fixed in 1.14.0
- github.com/kyverno/kyverno (Go): affected from 1.14.0-alpha.1; fixed in 1.14.0
- kyverno (Bitnami): affected all versions; fixed in 1.13.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46342/ (Markdown: https://insights.sbomify.com/CVE-2025-46342/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46342
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46342
- OSV: https://osv.dev/vulnerability/CVE-2025-46342

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46342/
Summaries are generated and may contain mistakes; the official description above is the record.
