# CVE-2025-46343: n8n Vulnerable to Stored XSS through Attachments View Endpoint

> An authenticated attacker can upload malicious HTML files to trigger stored XSS, potentially leading to account takeover of other users.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-c8hm-hr8h-5xjw

## What is CVE-2025-46343?

CVE-2025-46343 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 29 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

n8n is a workflow automation platform. Prior to version 1.90.0, n8n is vulnerable to stored cross-site scripting (XSS) through the attachments view endpoint. n8n workflows can store and serve binary files, which are accessible to authenticated users. However, there is no restriction on the MIME type of uploaded files, and the MIME type could be controlled via a GET parameter. This allows the server to respond with any MIME type, potentially enabling malicious content to be interpreted and executed by the browser. An authenticated attacker with member-level permissions could exploit this by uploading a crafted HTML file containing malicious JavaScript. When another user visits the binary data endpoint with the MIME type set to text/html, the script executes in the context of the user’s session. This script could send a request to change the user’s email address in their account settings, effectively enabling account takeover. This issue has been patched in version 1.90.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46343?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.90.0 |
| `n8n` | npm | All versions | 1.90.0 |

Products: N8n N8n.

## How do I fix CVE-2025-46343?

Upgrade n8n to 1.90.0 or later.

## Is CVE-2025-46343 being exploited?

There is no known exploitation of CVE-2025-46343 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46343 and fix it if it is affected.

What it is: CVE-2025-46343 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 29 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-46343 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.90.0
- n8n (npm): affected all versions; fixed in 1.90.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46343/ (Markdown: https://insights.sbomify.com/CVE-2025-46343/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46343
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46343
- OSV: https://osv.dev/vulnerability/CVE-2025-46343

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46343/
Summaries are generated and may contain mistakes; the official description above is the record.
