{"answers":{"affected":"2 open source packages ship an affected version, including @auth0/nextjs-auth0.","exploited":"There is no known exploitation of CVE-2025-46344 in the wild and no public exploit code.","fix":"Upgrade @auth0/nextjs-auth0 to 4.5.1 or later.","what":"CVE-2025-46344 is a medium-severity vulnerability in nextjs-auth0, published on 29 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46344 and fix it if it is affected.\n\nWhat it is: CVE-2025-46344 is a medium-severity vulnerability in nextjs-auth0, published on 29 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-46344 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.5.1\n- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46344/ (Markdown: https://insights.sbomify.com/CVE-2025-46344/index.md)","id":"CVE-2025-46344","markdown":"https://insights.sbomify.com/CVE-2025-46344/index.md","name":"CVE-2025-46344","record":{"aliases":["GHSA-pjr6-jx7r-j4r6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Next.js Auth0 SDK","requires_auth":"low_privilege","summary":"Attackers can maintain persistent access because session tokens lack internal expiration claims, allowing continued use after cookie expiry.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth0 NextJS SDK v4 Missing Session Invalidation","id":"CVE-2025-46344","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Auth0 Account Link Extension JWT Invalid Signature Validation","id":"CVE-2025-46345"},"packages":[{"ecosystem":"npm","fixed":["4.5.1"],"introduced":["4.0.1"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":null,"source":"GHSA-pjr6-jx7r-j4r6"},{"ecosystem":"npm","fixed":["4.5.1"],"introduced":["4.0.1"],"last_affected":[],"package":"@auth0/nextjs-auth0","purl":"pkg:npm/%40auth0/nextjs-auth0","source":"GHSA-pjr6-jx7r-j4r6"}],"prev":{"headline":"n8n Vulnerable to Stored XSS through Attachments View Endpoint","id":"CVE-2025-46343"},"products":["nextjs-auth0"],"published":"2025-04-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["auth0"]},"summary":"Attackers can maintain persistent access because session tokens lack internal expiration claims, allowing continued use after cookie expiry.","url":"https://insights.sbomify.com/CVE-2025-46344/"}