# CVE-2025-46344: Auth0 NextJS SDK v4 Missing Session Invalidation

> Attackers can maintain persistent access because session tokens lack internal expiration claims, allowing continued use after cookie expiry.

- **Severity:** Medium 4.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-pjr6-jx7r-j4r6

## What is CVE-2025-46344?

CVE-2025-46344 is a medium-severity vulnerability in nextjs-auth0, published on 29 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions starting from 4.0.1 and prior to 4.5.1, do not invoke `.setExpirationTime` when generating a JWE token for the session. As a result, the JWE does not contain an internal expiration claim. While the session cookie may expire or be cleared, the JWE remains valid. This issue has been patched in version 4.5.1.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-46344?

2 open source packages ship an affected version, including @auth0/nextjs-auth0.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@auth0/nextjs-auth0` | npm | From 4.0.1 | 4.5.1 |
| `@auth0/nextjs-auth0` | npm | From 4.0.1 | 4.5.1 |

## How do I fix CVE-2025-46344?

Upgrade @auth0/nextjs-auth0 to 4.5.1 or later.

## Is CVE-2025-46344 being exploited?

There is no known exploitation of CVE-2025-46344 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46344 and fix it if it is affected.

What it is: CVE-2025-46344 is a medium-severity vulnerability in nextjs-auth0, published on 29 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46344 in the wild and no public exploit code.

Affected packages and fixed versions:
- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.5.1
- @auth0/nextjs-auth0 (npm): affected from 4.0.1; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46344/ (Markdown: https://insights.sbomify.com/CVE-2025-46344/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46344
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46344
- OSV: https://osv.dev/vulnerability/CVE-2025-46344

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46344/
Summaries are generated and may contain mistakes; the official description above is the record.
