{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46348 exists.","fix":"Upgrade yeswiki/yeswiki to 4.5.4 or later.","what":"CVE-2025-46348 is a critical missing authorization vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46348 and fix it if it is affected.\n\nWhat it is: CVE-2025-46348 is a critical missing authorization vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46348 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.4\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46348/ (Markdown: https://insights.sbomify.com/CVE-2025-46348/index.md)","id":"CVE-2025-46348","markdown":"https://insights.sbomify.com/CVE-2025-46348/index.md","name":"CVE-2025-46348","record":{"aliases":["GHSA-wc9g-6j9w-hr95"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki","requires_auth":"none","summary":"Unauthenticated attackers can create and download site backups, exposing sensitive data and potentially causing denial of service via disk exhaustion.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yeswiki","vendor":"yeswiki"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"YesWiki is a wiki system written in PHP. Prior to version 4.5.4, the request to commence a site backup can be performed and downloaded without authentication. The archives are created with a predictable filename, so a malicious user could create and download an archive without being authenticated. This could result in a malicious attacker making numerous requests to create archives and fill up the file system, or by downloading the archive which contains sensitive site information. This issue has been patched in version 4.5.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download","id":"CVE-2025-46348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting","id":"CVE-2025-46349"},"packages":[{"ecosystem":"Packagist","fixed":["4.5.4"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-wc9g-6j9w-hr95"},{"ecosystem":"Packagist","fixed":["4.5.4"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-wc9g-6j9w-hr95"}],"prev":{"headline":"YesWiki Remote Code Execution via Arbitrary PHP File Write and Execution","id":"CVE-2025-46347"},"products":["yeswiki"],"published":"2025-04-29","related":[{"cvss_score":9.9,"headline":"Use of a Broken or Risky Cryptographic Algorithm in YesWiki","id":"CVE-2024-51478","kev_date_added":null,"published":"2024-10-31"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2018-1000641","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":8.6,"headline":"Path Traversal allowing arbitrary read of files in Yeswiki","id":"CVE-2025-31131","kev_date_added":null,"published":"2025-04-01"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting","id":"CVE-2025-46349","kev_date_added":null,"published":"2025-04-29"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Unauthenticated DOM Based XSS","id":"CVE-2025-24017","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Authenticated Stored XSS","id":"CVE-2025-24018","kev_date_added":null,"published":"2025-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["YesWiki"]},"summary":"Unauthenticated attackers can create and download site backups, exposing sensitive data and potentially causing denial of service via disk exhaustion.","url":"https://insights.sbomify.com/CVE-2025-46348/"}