# CVE-2025-46348: YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download

> Unauthenticated attackers can create and download site backups, exposing sensitive data and potentially causing denial of service via disk exhaustion.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-wc9g-6j9w-hr95

## What is CVE-2025-46348?

CVE-2025-46348 is a critical missing authorization vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, the request to commence a site backup can be performed and downloaded without authentication. The archives are created with a predictable filename, so a malicious user could create and download an archive without being authenticated. This could result in a malicious attacker making numerous requests to create archives and fill up the file system, or by downloading the archive which contains sensitive site information. This issue has been patched in version 4.5.4.

Weakness: CWE-862 (Missing Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-46348?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.4 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.4 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2025-46348?

Upgrade yeswiki/yeswiki to 4.5.4 or later.

## Is CVE-2025-46348 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46348 exists.

## Other vulnerabilities in yeswiki

- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)
- [CVE-2025-24017](https://insights.sbomify.com/CVE-2025-24017/): YesWiki Vulnerable to Unauthenticated DOM Based XSS (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46348 and fix it if it is affected.

What it is: CVE-2025-46348 is a critical missing authorization vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46348 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.4
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46348/ (Markdown: https://insights.sbomify.com/CVE-2025-46348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46348
- OSV: https://osv.dev/vulnerability/CVE-2025-46348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46348/
Summaries are generated and may contain mistakes; the official description above is the record.
