{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46349 exists.","fix":"No fix has been published for CVE-2025-46349 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-46349 is a high-severity cross-site scripting vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-46349 and fix it if it is affected.\n\nWhat it is: CVE-2025-46349 is a high-severity cross-site scripting vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46349 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions up to 4.5.3; no fix listed\n- yeswiki/yeswiki (Packagist): affected all versions up to 4.5.3; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46349/ (Markdown: https://insights.sbomify.com/CVE-2025-46349/index.md)","id":"CVE-2025-46349","markdown":"https://insights.sbomify.com/CVE-2025-46349/index.md","name":"CVE-2025-46349","record":{"aliases":["GHSA-2f8p-qqx2-gwr2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary scripts via reflected XSS in the file upload form, potentially compromising user accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yeswiki","vendor":"yeswiki"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2025/CVE-2025-46349.yaml","stars":null,"title":"YesWiki Reflected XSS via File Upload"}],"tier":"weaponised"},"has_fix":false,"headline":"YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting","id":"CVE-2025-46349","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Yeswiki Vulnerable to Authenticated Reflected Cross-site Scripting","id":"CVE-2025-46350"},"packages":[{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.5.3"],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-2f8p-qqx2-gwr2"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["4.5.3"],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-2f8p-qqx2-gwr2"}],"prev":{"headline":"YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download","id":"CVE-2025-46348"},"products":["yeswiki"],"published":"2025-04-29","related":[{"cvss_score":10,"headline":"YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download","id":"CVE-2025-46348","kev_date_added":null,"published":"2025-04-29"},{"cvss_score":9.9,"headline":"Use of a Broken or Risky Cryptographic Algorithm in YesWiki","id":"CVE-2024-51478","kev_date_added":null,"published":"2024-10-31"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2018-1000641","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":8.6,"headline":"Path Traversal allowing arbitrary read of files in Yeswiki","id":"CVE-2025-31131","kev_date_added":null,"published":"2025-04-01"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Unauthenticated DOM Based XSS","id":"CVE-2025-24017","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Authenticated Stored XSS","id":"CVE-2025-24018","kev_date_added":null,"published":"2025-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["YesWiki"]},"summary":"Unauthenticated attackers can execute arbitrary scripts via reflected XSS in the file upload form, potentially compromising user accounts.","url":"https://insights.sbomify.com/CVE-2025-46349/"}