# CVE-2025-46349: YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting

> Unauthenticated attackers can execute arbitrary scripts via reflected XSS in the file upload form, potentially compromising user accounts.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Apr 2025
- **Updated:** 29 Apr 2025
- **Also known as:** GHSA-2f8p-qqx2-gwr2

## What is CVE-2025-46349?

CVE-2025-46349 is a high-severity cross-site scripting vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-46349?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions to 4.5.3 | None |
| `yeswiki/yeswiki` | Packagist | All versions to 4.5.3 | None |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2025-46349?

No fix has been published for CVE-2025-46349 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-46349 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46349 exists.

Public exploit code:

- YesWiki Reflected XSS via File Upload (nuclei): http/cves/2025/CVE-2025-46349.yaml

## Other vulnerabilities in yeswiki

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-24017](https://insights.sbomify.com/CVE-2025-24017/): YesWiki Vulnerable to Unauthenticated DOM Based XSS (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46349 and fix it if it is affected.

What it is: CVE-2025-46349 is a high-severity cross-site scripting vulnerability in yeswiki, published on 29 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46349 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions up to 4.5.3; no fix listed
- yeswiki/yeswiki (Packagist): affected all versions up to 4.5.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46349/ (Markdown: https://insights.sbomify.com/CVE-2025-46349/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46349
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46349
- OSV: https://osv.dev/vulnerability/CVE-2025-46349

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46349/
Summaries are generated and may contain mistakes; the official description above is the record.
