# CVE-2025-4641: XML External Entity (XXE) injection vulnerability in WebDriverManager

> An XXE vulnerability in WebDriverManager allows attackers to cause denial of service or read sensitive data via malicious XML input.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:H/SC:H/SI:L/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-pwm3-776c-8q7q

## What is CVE-2025-4641?

CVE-2025-4641 is a critical vulnerability in bonigarcia webdrivermanager, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Restriction of XML External Entity Reference vulnerability in bonigarcia webdrivermanager WebDriverManager on Windows, MacOS, Linux (XML parsing components modules) allows Data Serialization External Entities Blowup. This vulnerability is associated with program files src/main/java/io/github/bonigarcia/wdm/WebDriverManager.java.

This issue affects webdrivermanager: from 1.0.0 before 6.0.2.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-4641?

2 open source packages ship an affected version, including io.github.bonigarcia:webdrivermanager.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.github.bonigarcia:webdrivermanager` | Maven | From 1.0.0 | 6.1.0 |
| `io.github.bonigarcia:webdrivermanager` | Maven | From 1.0.0 | 6.1.0 |

## How do I fix CVE-2025-4641?

Upgrade io.github.bonigarcia:webdrivermanager to 6.1.0 or later.

## Is CVE-2025-4641 being exploited?

There is no known exploitation of CVE-2025-4641 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4641 and fix it if it is affected.

What it is: CVE-2025-4641 is a critical vulnerability in bonigarcia webdrivermanager, published on 14 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4641 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.github.bonigarcia:webdrivermanager (Maven): affected from 1.0.0; fixed in 6.1.0
- io.github.bonigarcia:webdrivermanager (Maven): affected from 1.0.0; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4641/ (Markdown: https://insights.sbomify.com/CVE-2025-4641/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4641
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4641
- OSV: https://osv.dev/vulnerability/CVE-2025-4641

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4641/
Summaries are generated and may contain mistakes; the official description above is the record.
