# CVE-2025-4643: Lack of JWT Expiration after Log Out in PayloadCMS

> Attackers can reuse stolen JWTs after logout due to lack of token invalidation, allowing unauthorized access until expiration.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** GHSA-5v66-m237-hwf7

## What is CVE-2025-4643?

CVE-2025-4643 is a medium-severity vulnerability in Payload, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Payload uses JSON Web Tokens (JWT) for authentication. After log out JWT is not invalidated, which allows an attacker who has stolen or intercepted token to freely reuse it until expiration date (which is by default set to 2 hours, but can be changed). 

This issue has been fixed in version 3.44.0 of Payload.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2025-4643?

6 open source packages ship an affected version, including @payloadcms/graphql, @payloadcms/next and payload.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/graphql` | npm | All versions | 3.44.0 |
| `@payloadcms/graphql` | npm | All versions | 3.44.0 |
| `@payloadcms/next` | npm | All versions | 3.44.0 |
| `@payloadcms/next` | npm | All versions | 3.44.0 |
| `payload` | npm | All versions | 3.44.0 |
| `payload` | npm | All versions | 3.44.0 |

## How do I fix CVE-2025-4643?

Upgrade @payloadcms/graphql to 3.44.0 or later.

## Is CVE-2025-4643 being exploited?

There is no known exploitation of CVE-2025-4643 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4643 and fix it if it is affected.

What it is: CVE-2025-4643 is a medium-severity vulnerability in Payload, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4643 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/graphql (npm): affected all versions; fixed in 3.44.0
- @payloadcms/graphql (npm): affected all versions; fixed in 3.44.0
- @payloadcms/next (npm): affected all versions; fixed in 3.44.0
- @payloadcms/next (npm): affected all versions; fixed in 3.44.0
- payload (npm): affected all versions; fixed in 3.44.0
- payload (npm): affected all versions; fixed in 3.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4643/ (Markdown: https://insights.sbomify.com/CVE-2025-4643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4643
- OSV: https://osv.dev/vulnerability/CVE-2025-4643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4643/
Summaries are generated and may contain mistakes; the official description above is the record.
