{"answers":{"affected":"6 open source packages ship an affected version, including @payloadcms/graphql, @payloadcms/next and payload.","exploited":"There is no known exploitation of CVE-2025-4644 in the wild and no public exploit code.","fix":"Upgrade @payloadcms/graphql to 3.44.0 or later.","what":"CVE-2025-4644 is a medium-severity authentication bypass vulnerability in Payload, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-4644 and fix it if it is affected.\n\nWhat it is: CVE-2025-4644 is a medium-severity authentication bypass vulnerability in Payload, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-4644 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @payloadcms/graphql (npm): affected all versions; fixed in 3.44.0\n- @payloadcms/graphql (npm): affected all versions; fixed in 3.44.0\n- @payloadcms/next (npm): affected all versions; fixed in 3.44.0\n- @payloadcms/next (npm): affected all versions; fixed in 3.44.0\n- payload (npm): affected all versions; fixed in 3.44.0\n- payload (npm): affected all versions; fixed in 3.44.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4644/ (Markdown: https://insights.sbomify.com/CVE-2025-4644/index.md)","id":"CVE-2025-4644","markdown":"https://insights.sbomify.com/CVE-2025-4644/index.md","name":"CVE-2025-4644","record":{"aliases":["GHSA-26rv-h2hf-3fw4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Payload CMS","requires_auth":"none","summary":"Attackers can hijack new user accounts by reusing JWTs from deleted accounts due to identifier reuse in the SQLite adapter.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CERT-PL","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-384","name":"Session Fixation"}],"description":"A Session Fixation vulnerability existed in Payload's SQLite adapter due to identifier reuse during account creation. A malicious attacker could create a new account, save its JSON Web Token (JWT), and then delete the account, which did not invalidate the JWT. As a result, the next newly created user would receive the same identifier, allowing the attacker to reuse the JWT to authenticate and perform actions as that user.\n\nThis issue has been fixed in version 3.44.0 of Payload.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"User Session Fixation after Account Removal in PayloadCMS","id":"CVE-2025-4644","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":6,"n_references":3,"next":{"headline":"Code injection in AXIS OS","id":"CVE-2025-4645"},"packages":[{"ecosystem":"npm","fixed":["3.44.0"],"introduced":["0"],"last_affected":[],"package":"@payloadcms/graphql","purl":null,"source":"GHSA-26rv-h2hf-3fw4"},{"ecosystem":"npm","fixed":["3.44.0"],"introduced":["0"],"last_affected":[],"package":"@payloadcms/graphql","purl":"pkg:npm/%40payloadcms/graphql","source":"GHSA-26rv-h2hf-3fw4"},{"ecosystem":"npm","fixed":["3.44.0"],"introduced":["0"],"last_affected":[],"package":"@payloadcms/next","purl":null,"source":"GHSA-26rv-h2hf-3fw4"},{"ecosystem":"npm","fixed":["3.44.0"],"introduced":["0"],"last_affected":[],"package":"@payloadcms/next","purl":"pkg:npm/%40payloadcms/next","source":"GHSA-26rv-h2hf-3fw4"},{"ecosystem":"npm","fixed":["3.44.0"],"introduced":["0"],"last_affected":[],"package":"payload","purl":null,"source":"GHSA-26rv-h2hf-3fw4"},{"ecosystem":"npm","fixed":["3.44.0"],"introduced":["0"],"last_affected":[],"package":"payload","purl":"pkg:npm/payload","source":"GHSA-26rv-h2hf-3fw4"}],"prev":{"headline":"Lack of JWT Expiration after Log Out in PayloadCMS","id":"CVE-2025-4643"},"products":["Payload"],"published":"2025-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-29","vendors":["Payload CMS"]},"summary":"Attackers can hijack new user accounts by reusing JWTs from deleted accounts due to identifier reuse in the SQLite adapter.","url":"https://insights.sbomify.com/CVE-2025-4644/"}