# CVE-2025-4644: User Session Fixation after Account Removal in PayloadCMS

> Attackers can hijack new user accounts by reusing JWTs from deleted accounts due to identifier reuse in the SQLite adapter.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** GHSA-26rv-h2hf-3fw4

## What is CVE-2025-4644?

CVE-2025-4644 is a medium-severity authentication bypass vulnerability in Payload, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Session Fixation vulnerability existed in Payload's SQLite adapter due to identifier reuse during account creation. A malicious attacker could create a new account, save its JSON Web Token (JWT), and then delete the account, which did not invalidate the JWT. As a result, the next newly created user would receive the same identifier, allowing the attacker to reuse the JWT to authenticate and perform actions as that user.

This issue has been fixed in version 3.44.0 of Payload.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2025-4644?

6 open source packages ship an affected version, including @payloadcms/graphql, @payloadcms/next and payload.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@payloadcms/graphql` | npm | All versions | 3.44.0 |
| `@payloadcms/graphql` | npm | All versions | 3.44.0 |
| `@payloadcms/next` | npm | All versions | 3.44.0 |
| `@payloadcms/next` | npm | All versions | 3.44.0 |
| `payload` | npm | All versions | 3.44.0 |
| `payload` | npm | All versions | 3.44.0 |

## How do I fix CVE-2025-4644?

Upgrade @payloadcms/graphql to 3.44.0 or later.

## Is CVE-2025-4644 being exploited?

There is no known exploitation of CVE-2025-4644 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4644 and fix it if it is affected.

What it is: CVE-2025-4644 is a medium-severity authentication bypass vulnerability in Payload, published on 29 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4644 in the wild and no public exploit code.

Affected packages and fixed versions:
- @payloadcms/graphql (npm): affected all versions; fixed in 3.44.0
- @payloadcms/graphql (npm): affected all versions; fixed in 3.44.0
- @payloadcms/next (npm): affected all versions; fixed in 3.44.0
- @payloadcms/next (npm): affected all versions; fixed in 3.44.0
- payload (npm): affected all versions; fixed in 3.44.0
- payload (npm): affected all versions; fixed in 3.44.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4644/ (Markdown: https://insights.sbomify.com/CVE-2025-4644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4644
- OSV: https://osv.dev/vulnerability/CVE-2025-4644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4644/
Summaries are generated and may contain mistakes; the official description above is the record.
