{"answers":{"affected":"8 open source packages ship an affected version, including rubygems:jruby-openssl, org.jruby:jruby and jruby-openssl. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46551 exists.","fix":"Upgrade rubygems:jruby-openssl to 0.15.4 or later.","what":"CVE-2025-46551 is a medium-severity vulnerability in jruby-openssl, published on 7 May 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-46551 and fix it if it is affected.\n\nWhat it is: CVE-2025-46551 is a medium-severity vulnerability in jruby-openssl, published on 7 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46551 exists.\n\nAffected packages and fixed versions:\n- rubygems:jruby-openssl (Maven): affected from 0.12.1; fixed in 0.15.4\n- rubygems:jruby-openssl (Maven): affected from 0.12.1; fixed in 0.15.4\n- org.jruby:jruby (Maven): affected from 10.0.0.0; fixed in 10.0.0.1\n- org.jruby:jruby (Maven): affected from 10.0.0.0; fixed in 10.0.0.1\n- org.jruby:jruby (Maven): affected from 9.3.4.0; fixed in 9.4.12.1\n- org.jruby:jruby (Maven): affected from 9.3.4.0; fixed in 9.4.12.1\n- jruby-openssl (RubyGems): affected from 0.12.1; fixed in 0.15.4\n- jruby-openssl (RubyGems): affected from 0.12.1; fixed in 0.15.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-46551/ (Markdown: https://insights.sbomify.com/CVE-2025-46551/index.md)","id":"CVE-2025-46551","markdown":"https://insights.sbomify.com/CVE-2025-46551/index.md","name":"CVE-2025-46551","record":{"aliases":["CLEANSTART-2026-OD65831","ECHO-b49a-ed3a-3f0a","GHSA-72qj-48g4-5xgx","MINI-775v-qpmr-4f92","MINI-9mh2-2r3m-m99q","MINI-mg84-gfww-c4fc","MINI-ph42-7rvj-qv2q","MINI-vqvj-prg7-mj3x","UBUNTU-CVE-2025-46551"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JRuby OpenSSL library","requires_auth":"low_privilege","summary":"JRuby-OpenSSL fails to verify hostnames in SSL certificates, allowing man-in-the-middle attacks against applications using JRuby for secure connections.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jruby","vendor":"jruby"},{"product":"jruby-openssl","vendor":"jruby"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"JRuby-OpenSSL is an add-on gem for JRuby that emulates the Ruby OpenSSL native library. Starting in JRuby-OpenSSL version 0.12.1 and prior to version 0.15.4 (corresponding to JRuby versions starting in 9.3.4.0 prior to 9.4.12.1 and 10.0.0.0 prior to 10.0.0.1), when verifying SSL certificates, JRuby-OpenSSL does not verify that the hostname presented in the certificate matches the one the user tries to connect to. This means a man-in-the-middle could just present any valid cert for a completely different domain they own, and JRuby would accept the cert. Anybody using JRuby to make requests of external APIs, or scraping the web, that depends on https to connect securely. JRuby-OpenSSL version 0.15.4 contains a fix for the issue. This fix is included in JRuby versions 10.0.0.1 and 9.4.12.1.","ecosystems":["Maven","RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"JRuby-OpenSSL has hostname verification disabled by default","id":"CVE-2025-46551","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":8,"n_references":2,"next":{"headline":"KHC-INVITATION-AUTOMATION Sensitive User Information Leakage in Invitation Automation","id":"CVE-2025-46552"},"packages":[{"ecosystem":"Maven","fixed":["10.0.0.1"],"introduced":["10.0.0.0"],"last_affected":[],"package":"org.jruby:jruby","purl":null,"source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"Maven","fixed":["10.0.0.1"],"introduced":["10.0.0.0"],"last_affected":[],"package":"org.jruby:jruby","purl":"pkg:maven/org.jruby/jruby","source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"Maven","fixed":["9.4.12.1"],"introduced":["9.3.4.0"],"last_affected":[],"package":"org.jruby:jruby","purl":null,"source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"Maven","fixed":["9.4.12.1"],"introduced":["9.3.4.0"],"last_affected":[],"package":"org.jruby:jruby","purl":"pkg:maven/org.jruby/jruby","source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"Maven","fixed":["0.15.4"],"introduced":["0.12.1"],"last_affected":[],"package":"rubygems:jruby-openssl","purl":null,"source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"Maven","fixed":["0.15.4"],"introduced":["0.12.1"],"last_affected":[],"package":"rubygems:jruby-openssl","purl":"pkg:maven/rubygems/jruby-openssl","source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"RubyGems","fixed":["0.15.4"],"introduced":["0.12.1"],"last_affected":[],"package":"jruby-openssl","purl":null,"source":"GHSA-72qj-48g4-5xgx"},{"ecosystem":"RubyGems","fixed":["0.15.4"],"introduced":["0.12.1"],"last_affected":[],"package":"jruby-openssl","purl":"pkg:gem/jruby-openssl","source":"GHSA-72qj-48g4-5xgx"}],"prev":{"headline":"Yeswiki Vulnerable to Unauthenticated Reflected Cross-site Scripting","id":"CVE-2025-46550"},"products":["jruby-openssl"],"published":"2025-05-07","related":[{"cvss_score":5,"headline":"JRuby denial of service via Hash Collision","id":"CVE-2012-5370","kev_date_added":null,"published":"2012-11-28"},{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2011-4838","kev_date_added":null,"published":"2011-12-30"},{"cvss_score":4.3,"headline":"Cross-site Scripting in in JRuby","id":"CVE-2010-1330","kev_date_added":null,"published":"2012-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-07","vendors":["jruby"]},"summary":"JRuby-OpenSSL fails to verify hostnames in SSL certificates, allowing man-in-the-middle attacks against applications using JRuby for secure connections.","url":"https://insights.sbomify.com/CVE-2025-46551/"}