# CVE-2025-46554: XWiki missing authorization when accessing the wiki level attachments list and metadata via REST API

> Unauthenticated attackers can access attachment metadata via REST API due to missing authorization checks in XWiki.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Apr 2025
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-r5cr-xm48-97xp

## What is CVE-2025-46554?

CVE-2025-46554 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki is a generic wiki platform. In versions starting from 1.8.1 to before 14.10.22, from 15.0-rc-1 to before 15.10.12, from 16.0.0-rc-1 to before 16.4.3, and from 16.5.0-rc-1 to before 16.7.0, anyone can access the metadata of any attachment in the wiki using the wiki attachment REST endpoint. There is no filtering for the results depending on current user rights, meaning an unauthenticated user could exploit this even in a private wiki. This issue has been patched in versions 14.10.22, 15.10.12, 16.4.3, and 16.7.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-46554?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-rest-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8.1 | 14.10.22 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 1.8.1 | 14.10.22 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 15.0-rc-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 15.0-rc-1 | 15.10.12 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.0.0-rc-1 | 16.4.3 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.0.0-rc-1 | 16.4.3 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.5.0-rc-1 | 16.7.0 |
| `org.xwiki.platform:xwiki-platform-rest-server` | Maven | From 16.5.0-rc-1 | 16.7.0 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-46554?

Upgrade org.xwiki.platform:xwiki-platform-rest-server to a fixed version for your release line: 14.10.22, 15.10.12, 16.4.3 or 16.7.0.

## Is CVE-2025-46554 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46554 exists.

Public exploit code:

- XWiki REST API - Attachments Disclosure (nuclei): http/cves/2025/CVE-2025-46554.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46554 and fix it if it is affected.

What it is: CVE-2025-46554 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-46554 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8.1; fixed in 14.10.22
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 1.8.1; fixed in 14.10.22
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 15.0-rc-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 15.0-rc-1; fixed in 15.10.12
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.0.0-rc-1; fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.0.0-rc-1; fixed in 16.4.3
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.5.0-rc-1; fixed in 16.7.0
- org.xwiki.platform:xwiki-platform-rest-server (Maven): affected from 16.5.0-rc-1; fixed in 16.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46554/ (Markdown: https://insights.sbomify.com/CVE-2025-46554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46554
- OSV: https://osv.dev/vulnerability/CVE-2025-46554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46554/
Summaries are generated and may contain mistakes; the official description above is the record.
