# CVE-2025-46556: MantisBT is Vulnerable to Denial-of-Service (DoS) attack via Excessive Note Length

> Attackers can corrupt issue activity logs by submitting excessively long notes, breaking the UI and preventing future collaboration on issues.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Nov 2025
- **Updated:** 6 Nov 2025
- **Also known as:** GHSA-r3jf-hm7q-qfw5

## What is CVE-2025-46556?

CVE-2025-46556 is a medium-severity denial of service vulnerability in Mantisbt Mantisbt, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mantis Bug Tracker (MantisBT) is an open source issue tracker. Versions 2.27.1 and below allow attackers to permanently corrupt issue activity logs by submitting extremely long notes (tested with 4,788,761 characters) due to a lack of server-side validation of note length. Once such a note is added, the activity stream UI fails to render; therefore, new notes cannot be displayed, effectively breaking all future collaboration on the issue. This issue is fixed in version 2.27.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-46556?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.27.2 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.27.2 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2025-46556?

Upgrade mantisbt/mantisbt to 2.27.2 or later.

## Is CVE-2025-46556 being exploited?

There is no known exploitation of CVE-2025-46556 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-46556 and fix it if it is affected.

What it is: CVE-2025-46556 is a medium-severity denial of service vulnerability in Mantisbt Mantisbt, published on 4 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-46556 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.27.2
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.27.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-46556/ (Markdown: https://insights.sbomify.com/CVE-2025-46556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-46556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-46556
- OSV: https://osv.dev/vulnerability/CVE-2025-46556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-46556/
Summaries are generated and may contain mistakes; the official description above is the record.
