CVE-2025-46557 Any user with view access to the XWiki space can change the authenticator
Users with view access can change the authentication mechanism, potentially bypassing SSO or breaking login functionality.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-46557?
CVE-2025-46557 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
XWiki is a generic wiki platform. In versions starting from 15.3-rc-1 to before 15.10.14, from 16.0.0-rc-1 to before 16.4.6, and from 16.5.0-rc-1 to before 16.10.0-rc-1, a user who can access pages located in the XWiki space (by default, anyone) can access the page XWiki.Authentication.Administration and (unless an authenticator is set in xwiki.cfg) switch to another installed authenticator. Note that, by default, there is only one authenticator available (Standard XWiki Authenticator). So, if no authenticator extension was installed, it's not really possible to do anything for an attacker. Also, in most cases, if an SSO authenticator is installed and utilized (like OIDC or LDAP for example), the worst an attacker can do is break authentication by switching back to the standard authenticator (that's because it's impossible to login to a user which does not have a stored password, and that's usually what SSO authenticator produce). This issue has been patched in versions 15.10.14, 16.4.6, and 16.10.0-rc-1.
Weakness: CWE-862
Which versions are affected by CVE-2025-46557?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authentication-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-security-authentication-ui Maven | From 15.3-rc-1 | 15.10.14 |
org.xwiki.platform:xwiki-platform-security-authentication-ui Maven | From 15.3-rc-1 | 15.10.14 |
org.xwiki.platform:xwiki-platform-security-authentication-ui Maven | From 16.0.0-rc-1 | 16.4.6 |
org.xwiki.platform:xwiki-platform-security-authentication-ui Maven | From 16.0.0-rc-1 | 16.4.6 |
org.xwiki.platform:xwiki-platform-security-authentication-ui Maven | From 16.5.0-rc-1 | 16.10.0-rc-1 |
org.xwiki.platform:xwiki-platform-security-authentication-ui Maven | From 16.5.0-rc-1 | 16.10.0-rc-1 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-46557?
Upgrade org.xwiki.platform:xwiki-platform-security-authentication-ui to a fixed version for your release line: 15.10.14, 16.4.6 or 16.10.0-rc-1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-46557 being exploited?
There is no known exploitation of CVE-2025-46557 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-f9c6-2f9p-82jj.